В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
daryaromanchuk
daryaromanchuk
01.06.2020 05:17 •  Информатика

Написать программу( желательно си++). Дана непустая последовательность литер, оканчивающаяся точкой.Определить, удовлетворяет ли она следующему свойству: последовательность совпадает с каким-то отрезком ряда 0123456789

Показать ответ
Ответ:
Dаniеll
Dаniеll
26.11.2020 11:05

#include <iostream>

using namespace std;

int main() {

string s;

string ss("0123456789");

getline(cin, s);

if(s[s.length()-1!='.']) {

 s+=".";

}

string temp;

for(int i = 0; i<ss.length(); ++i) {

 temp+=ss[i];

 if(s.find(temp)!=-1) {

  cout << "yes";

 return 0;

 }

}

cout << "no";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота