Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
annamironova6941
05.01.2020 18:59 •
Информатика
Написать программы 1. дано целое число n (> 0). если n — нечетное, то вывести произведение 1•3••n; если n — четное, то вывести произведение 2•4••n. 2. вывести на экран таблицу значений функции x2 на отрезке[0,1] с шагом 0.1.
Показать ответ
Ответ:
ivankn
01.10.2020 21:05
1.
#include <iostream>
using namespace std;
int main()
{
int i,j,a,b,n;
cin >> n;
a=1;
if (n % 2 == 1) {
for (i=1;i<=n;){
a=a*i;
i=i+2;
}}
else {
for (i=2;i<=n;){
a*=i;
i+=2;
}
}
cout << a;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
алгебра107
02.04.2022 14:09
Склавиатуры вводятся n целых чисел, по модулю не превышающих 30 000. найти среднее значение положительных чисел, кратных 9....
sashaopalko123
13.01.2022 23:47
Засіб, який дозволяє введення даних, що відповідають визначеним умовам....
superkurmaleev
09.01.2023 22:08
Перечислите направления робототехники Приведите примеры каждого перечисленного вида...
mehemmed20039
21.07.2020 10:15
Блок схема y= x+4/2x-1...
MarGGoTV
15.10.2021 09:31
Заполните в тетради таблицу, в каждой строке которой одно и то же число должно быть записано в системах счисления с основаниями 2, 8, 10 и 16. только с решение...
edvinmanovskij
01.11.2022 20:32
Даны переменные A B C изменить их значения переместив содержимое A в С,С-в В,В- А и вывести новые значения переменных А,B,C. s++...
Katrin8745
25.04.2022 22:18
Алгоритм вычисления функции F(n), где n – целое неотрицательное число, задан следующими соотношениями: F(0) = 1 F(n) = F(n–1) + F(n–2), при чётном n 0 F(n) = 1,5*F(n–1), при нечётном...
ома7
14.05.2020 05:14
С решением! Переведрте числа 163¹⁰ в двоичную восьмеричную и шестнадцатеричную систему счисления! С решением!...
Проgh
09.10.2022 04:08
сколько гб в мб и сколько байт в мигобайтах...
юлия30885
22.02.2023 09:04
Что такое степень сжатия?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
using namespace std;
int main()
{
int i,j,a,b,n;
cin >> n;
a=1;
if (n % 2 == 1) {
for (i=1;i<=n;){
a=a*i;
i=i+2;
}}
else {
for (i=2;i<=n;){
a*=i;
i+=2;
}
}
cout << a;
}