В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kristibabiba098
Kristibabiba098
20.02.2022 08:13 •  Информатика

Написать в C# и составить блок-схему:
Напишите программу, которая выводит на экран фразу «Всем привет» 80
раз – в таблице из 20 строк по 4 столбца. Для расстояния между колонками
использовать 5 пробелов

Показать ответ
Ответ:
Ринаqq
Ринаqq
17.12.2020 13:43

program D1;

uses GraphABC;

const c: array[1..3] of integer = (15,20,65);

n: array[1..3] of string = (' Белки ',' Жиры ',' Углеводы ');

var nu,u, i: integer;

begin

SetWindowTitle ('Сбалансированное питание');

SetFontSize(15);

TextOut(185,30,'Сбалансированное питание');

SetFontSize(10);

nu:=0;

for i:=1 to 3 do

begin

case i of

1: SetBrushColor(clred);

2: SetBrushColor(clgreen);

3: SetBrushColor(clblue)

end;

TextOut(285,385+(i*20),n[i]+IntToStr(c[i])+' % ');

u:=nu+trunc(c[i]*360/100);

Pie(320,230,150,nu,u);

nu:=u;

end;

SaveWindow ('Диаграмма питания.bmp')

end.

Объяснение:

картинка

0,0(0 оценок)
Ответ:
nezandenzar
nezandenzar
06.02.2022 04:56

X=30

q=1

w=2

e=3

r=4

list=[q,w,e,r]

for i in list:

   if i==X and i==q:

       print(f'Нужен ящик q')

   if i==X and i==w:

        print(f'Нужен ящик w')

   if i==X and i==e:

        print(f'Нужен ящик e')

   if i==X and i==r:

        print(f'Нужен ящик r')    

if e+r==X:

   print(f'Нужны ящики e и r')

if w+r==X:

   print(f'Нужны ящики w и r')

if w+e==X:

   print(f'Нужны ящики w и e')

if q+r==X:

   print(f'Нужны ящики q и r')

if q+e==X:

   print(f'Нужны ящики q и e')

if q+w==X:

   print(f'Нужны ящики q и w')

if w+e+r==X:

   print(f'Нужны ящики w, e и r')

if q+e+r==X:

   print(f'Нужны ящики q, e и r')

if q+w+r==X:

   print(f'Нужны ящики q, w и r')

if q+w+e==X:

   print(f'Нужны ящики q, w и e')

else:

   print('Нет таких ящиков')

Объяснение:

В кратце: я предполагаю, что количество ящиков по 1шт (q,w,e,r). Далее я пробегаюсь по всем возможных вариантам, каким образом можно получить из q,w,e,r X кг

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота