В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rustiuh
rustiuh
01.01.2021 04:37 •  Информатика

Напишите 2 программы на паскале.
Нужно написать программу математического выражения


Напишите 2 программы на паскале. Нужно написать программу математического выражения

Показать ответ
Ответ:
gamer2222
gamer2222
04.12.2022 11:40
Const
  n = 10;
var
  a: array[1..n] of integer;
  i, j, t: integer;
  flag:boolean;
 
begin
  Randomize;
  Writeln('Исходный массив');
  for i := 1 to n do
  begin
    a[i] := random(101)-50;
    Write(a[i]:4)
  end;
  Writeln;
  i:=1;
  repeat
    flag:=true;
    for j := 1 to n-i do
      if a[j] > a[j+1] then
      begin t := a[j]; a[j] := a[j+1]; a[j+1] := t; flag:=false end;
    Inc(i);
  until (i>n-1) or flag;
  Writeln('Отсортированный по возрастанию массив');
  for i := 1 to n do Write(a[i]:4);
  Writeln
end.

Тестовое решение:
Исходный массив
 -32  -7   2   2  50 -33   1  31   4 -16
Отсортированный по возрастанию массив
 -33 -32 -16  -7   1   2   2   4  31  50
0,0(0 оценок)
Ответ:
daniilzagora
daniilzagora
02.02.2022 20:31

Microsoft Еxcel -1979 жылы екі экономист студент Дэн Бриклин және Боб Френкстон үй тапсырмасын тез орындауға көмектесетін және уақытты үнемдейтін әдіс ойлап табуды шешті. олар тарихта бірінші рет электронды кесте бағдарламасын жазып, оны Visible Calculator сөзінен қысқартылған VisiCalc (Көрсеткіш калькулятор) деп атады. сондықтан барлық электрондық кестелер бағдарламасы, оның ішінде Excel программасы Дэн мен Бобтың арқасында жүзеге асты. IBM және Macintosh компьютерлерінде жұмыс істейтін, ең озық үлгілерді ала отырып, бүгінгі заман талабына сай жасалған, электрондық кесте құрастыратын қолданбалы программа. Excel-дің соңғы нұсқаларында график тұрғызу, күрделі функциялар арқылы есеп-қисап жүргізу және бірнеше жұмыс кітаптарымен қатар жұмыс атқару сияқты мүмкіндіктер кеңінен қолданылады. Кестелік құрылымды құжаттармен жұмыс істеуге арналған кең таралған құралдардың бірі Microsoft Excel. Ол сандық мәліметтермен жұмыс істеу үшін негізделген.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота