В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anaradocina
anaradocina
26.05.2021 19:39 •  Информатика

Напишите 2 простые программы на C++ 1. Задать одномерный массив целых чисел. И образовать из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа.

2. Генератором случайных чисел задан одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива.

Показать ответ
Ответ:
Lera246hh
Lera246hh
18.12.2020 12:53

1.

#include <iostream>

#include <vector>

using namespace std;

int main(){

int a,b;

cin>>a;

vector<int> v1;

vector<int> v2;

for(int i=0; i<a; i++){

cin>>b;

if (b%2==0) v1.emplace_back(b);

else v2.emplace_back(b);

}

sort(v1.begin(), v1.end());

sort(v2.begin(), v2.end());

for(auto & i: v1) cout<<i<<" ";

}

2.

#include <iostream>

#include <vector>

using namespace std;

int main(){

vector<float> v;

//здесь нам задают массив

sort(v.begin(), v.end());

cout<<v[0]<<v.back();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота