Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vovaonuchko
01.12.2021 01:30 •
Информатика
Напишите функцию function reverse (n: integer): integer (pascal), которая переставляет цифры числа в обратном порядке .
Показать ответ
Ответ:
nat17akan
23.09.2020 23:51
Function reverse(n:integer):integer;
var m:integer;
begin
m:=0;
while n>0 do
begin
m:=m*10+n mod 10;
n:=n div 10;
end;
reverse:=m;
end;
begin
writeln(reverse(12345));
end.
Результат:
54321
0,0
(0 оценок)
Популярные вопросы: Информатика
saha174zxcvb
23.05.2020 09:21
Программирование на Pascal...
лёха1920
26.09.2021 01:07
Информатика PYTHON, задача, что не так в моём коде Дано 3 целых числа. Выведите на экран: Максимум равен N , где N - наибольшее из трёх чисел. Формат входных данных С клавиатуры...
simasmirnovawww
22.07.2021 02:05
Мариям хочет применить к таблице функцию условного форматирования. Для этого она выбрала в «Правилах тбора первых и последних значений» параметр «Ниже среднего».Исходная таблица:...
Бекзатажеси
20.02.2023 05:15
Комплекс БД и СУБД называют...
AndreyDixord
11.08.2020 13:53
Убедитесь что следующие шесть функций тождественны...
limon4ikru
11.09.2021 20:59
1) (p+k*4)/(4*t)-4*p*k/(3-2*b) 2)(x1**3-y1**3)-(x**3-2)3) abs(4*x)+(3-3x)/5*y4)abs(3-x)+x**3/y**2...
SelfishDog
06.07.2020 13:39
Сколько килобайт информации содержит сообщение обемом 2^17 бит...
layci
29.11.2020 20:07
С ИНФОЙ! На дисплее планшетного компьютера в режиме чтения помещается 32 строки, каждая из которых содержит 64 символа. Содержит 50 страниц Определите ее информационный объем...
11111222А
24.06.2022 03:10
К какому поколению относятся компьютеры, на которых вы работаете?...
skarpion83
31.01.2023 15:08
Замените описание композиторов в предыдущем HTML коде. отправьте скриншот результатов...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var m:integer;
begin
m:=0;
while n>0 do
begin
m:=m*10+n mod 10;
n:=n div 10;
end;
reverse:=m;
end;
begin
writeln(reverse(12345));
end.
Результат:
54321