В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Svetakim0934
Svetakim0934
30.09.2020 14:21 •  Информатика

Напишите функцию search для поиска первого вхождения заданного значения в массиве целых чисел, которая как результат возвращает индекс найденного элемента.

перегрузите эту функцию так, чтобы она могла работать с массивом вещественных чисел. в случае, если в массиве искомого элемента нет, функция должна вернуть значение -1.

для двух массивов - целочисленного и вещественного - выведите индексы первого вхождения заданных элементов.

формат входных данных
в первой строке вводится натуральное число n1 (n1 ≤ 1) - размер первого массива.

в следующей строке вводятся n1 целых чисел, по модулю не превосходящих 109.

далее вводится одно целое число, по модулю не превосходящее 109 - искомое значение.

в следующей строке вводится натуральное число n2 (n2 ≤ 1) - размер второго массива.

в следующей строке вводятся n2 вещественных чисел, заданных с точностью до 6 знаков после точки и по модулю не превосходящих 109.

далее вводится одно вещественное число с точностью до 6 знаков после точки и по модулю не превосходящее 109 - искомое значение.

формат выходных данных
в первой строке выведите результат поиска в первом массиве, а во второй -- во втором массиве

входные данные
5

68 52 14 61 96

61

6

30.89 58.12 3416 58.12 6.279 368.9

58.12

выходные данные
3

1​

Показать ответ
Ответ:
aArisha2772
aArisha2772
27.10.2020 20:18

mobile_devices = {

   'cucuPhone': 2010,

   'cucuBlet': 2013,

   'cucuClock': 2015,

   'cucuEar': 2018,

   'cuCube': 2015,

}

home_devices = {

   'cucuLot': 2011,

   'cucuBlock': 2010,

   'cucuWall': 2010,

   'cucuMonitor': 2020,

   'cucuLamp': 2015,

   'cucuTable': 2016,

   'cucuTV': 2017,

}

not_supported_devices = {'cucuBlock', 'cucuBlet', 'cucuWall'}

result_supported = {}

# Функция объединяет ключи двух словарей в один set и возвращает его

def union_devices(devices_obj_1, devices_obj_2):

   set_1 = set(devices_obj_1)

   set_2 = set(devices_obj_2)

   union_set = set_1.union(set_2)

   return union_set

# Функция находит разницу двух сетов и возвращает её в виде set

def difference_device(all_devices, not_supported_devices):

   diff_set = all_devices.difference(not_supported_devices)

   return diff_set

# Функция копирует элементы из исходных словарей в результирующий словарь

def is_supported(dict_devices, device):

   if device in dict_devices:

       result_supported[device] = dict_devices[device]

# Вызываем union_devices(), чтобы получить полный перечень устройств

all_devices = union_devices(mobile_devices, home_devices)

# В result_devices сохранить сет, который вернёт функция difference_device()

result_devices = difference_device(all_devices, not_supported_devices)

# Перебрать в цикле сет result_devices и для каждого элемента  

# дважды вызвать функцию is_supported:

# - с аргументами mobile_devices, device

# - и с аргументами home_devices, device

for device in result_devices:

   is_supported(mobile_devices, device)

   is_supported(home_devices, device)

print(result_supported)

Объяснение:


Задача 3 Всемирно известная компания Cucumber выпускает мобильные гаджеты и устройства для «умного
Задача 3 Всемирно известная компания Cucumber выпускает мобильные гаджеты и устройства для «умного
0,0(0 оценок)
Ответ:
nastya2737
nastya2737
10.11.2022 23:26

ответ:РЕЖИМЫ ДАТЧИКА СВЕТА:

режим “Цвет”. Датчик цвета умеет определять семь различных цветов: черный, синий, зеленый, желтый, красный, белый и коричневый цвета. Также если цвет определяется некорректно если предмет назодится далеко от датчика. Датчик определяет отсутствие цвета и приходит в состояние «без цвета». Режим “Яркость отраженного света”.

РЕЖИМ ЯРКОСТЬ ОТРАЖЕННОГО СВЕТА:

В режиме «яркость отраженного света» датчик цвета определяет яркость света, отраженного света светодиода датчика излучающего красный свет . Датчик использует шкалу от 0 (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он двигался по белой поверхности до тех пор, пока не будет обнаружена черная линия, или чтобы он интерпретировал идентификационную карточку с цветовым кодом.

РЕЖИМ ЯРКОСТЬ ВНЕШНЕГО ОСВЕЩЕНИЯ:

В режиме«яркость внешнего освещения» датчик цвета определяет силу света, входящего в окошко из окружающей среды, например солнечного света или луча фонарика . Датчик использует шкалу от 0 (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он подавал сигнал утром, когда восходит солнце, или чтобы он прекращал действие, если свет гаснет .

РЕЖИМ ЦВЕТОВ:

Частота выборки датчика цвета составляет 1 кГц.

Для наибольшей точности при выборе режима «Цвет» или «Яркость отраженного света» датчик следует расположить под прямым углом на расстоянии 10-15 мм к исследуемой поверхности, но не касаясь ее .

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота