В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Милана4455
Милана4455
23.03.2023 22:32 •  Информатика

НАПИШИТЕ КОД НА PYTHON
ЗАРАНЕЕ Кривая дракона — один из наиболее известных фракталов. Она строится так: на первом шаге проводится отрезок из начала координатной плоскости в точку (0;1). Далее на каждом шаге из конца фрактала повторяется уже нарисованная часть фигуры, повернутая на 90 градусов против часовой стрелки.

https://edu.sirius.online/noo-back/content/_image/b0cbb1e584ca55a3ad45493f2cca431d14ddc166

Рассмотрим кривую дракона на шаге номер ≥ 2. Вы движетесь из точки (0,0) и выписываете направления поворотов после прохождения каждого отрезка. Поворот направо обозначается буквой R, поворот налево — буквой . Выведите последовательность поворотов.

Входные данные:
Задано натуральное число (2≤≤15).

Выходные данные:
Программа должна вывести последовательность из букв и в одной строке без пробелов.

Примеры
Ввод
3, 4
Вывод
RRL, RRLRRLL

Показать ответ
Ответ:
Mockov
Mockov
02.04.2021 04:37
// ConsoleApplication60.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include<conio.h>#include"iostream"#include "stdio.h"#include "time.h"
using namespace std;
int main(){ int x, y,c; setlocale(LC_ALL, "RUS"); srand((unsigned)time(NULL)); x = rand() % 8 + 2; y = rand() % 8 + 2; cout << "Сколько будет  " << x << "*" << y << "?" << "\n"; cout << "Введите ответ и нажмите Enter  "; cin >> c; if (x*y == c) { cout << "Правильно\n";  } else { cout << "Вы ошиблись   " << x << "*" << y << "=" << c;  } return 0;}
0,0(0 оценок)
Ответ:
8алина82
8алина82
08.02.2021 01:46
1. Компьютеры одной организации, связанные каналами передачи информации длясовместного использования общих ресурсов и периферийных устройств и находящиеся водном здании, называют сетью:
3) локальной

2. Компьютер, предоставляющий свои ресурсы другим компьютерам при совместной работе,называется:
2) сервером

3) Выберите правильные ответы:
1) Каждый компьютер, подключенный к локальной сети, должен иметь сетевую карту
Неверные ответы:
2) Одноранговые сети используются в том случае, если в локальной сети более 10 компьютеров (одноранговые сети как правило используются для маленьких сетей)
3) Сервер – это мощный компьютер, необходимый для более надежной работы локальной сети (сервер как правило, но не обязательно, мощнее, но уж точно нужен не для надёжности)
4) Сеть на основе сервера – когда все компьютеры локальной сети равноправны (не все равноправны - есть сервер и клиенты)

4. Интернет – это:
3) глобальная сеть

8. Сети, объединяющие компьютеры в пределах одного региона:
2) региональные

9. Сети, объединяющие компьютеры в пределах одной отрасли, корпорации:
3) корпоративные

10. Выберите из предложенного списка IP-адрес:
1. 193.126.7.29 (IP-адрес версии 4 - 4 числа от 0 до 255, разделённых точками)

12. Web-браузер – это:
4) клиент-программа WWW, обеспечивающая пользователю доступ к информационным ресурсам Интернета 

13. Сеть, в которой каждый пользователь сам решает вопрос доступа к своим файлам, называют
3) одноранговой компьютерной сетью

14. Компьютер, подключенный к Интернет, обязательно имеет:
1) IP-адрес
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота