В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DozZzuM
DozZzuM
01.06.2023 09:42 •  Информатика

Напишите код программы:  Ученик 9-го класса собирал данные о температуре воздуха в течение 20 дней. Результаты он записал в список a. Нужно составить программу, которая определяет количество дней с температурой воздуха выше 3 градусов.​

Показать ответ
Ответ:
leryush1
leryush1
04.03.2021 18:28

На Паскале:

program prog;

var

   a:array[1..20] of integer = (1,3,2,5,3,2,1,3,5,2,6,3,5,6,2,3,4,5,7,6);

   i,c:integer;

begin

   c:=0;

   for i:=1 to 20 do if a[i]>3 then c:=c+1;

   write('Количество дней с температурой воздуха больше 3 градусов: ', c);

end.

На Питоне:

c = 0

a = [1,3,2,5,3,2,1,3,5,2,6,3,5,6,2,3,4,5,7,6]

for i in a:

   if i > 3: c+=1

print(f'Количество дней с температурой воздуха больше 3 градусов: {c}')

Если нужно вводить температуру с клавиатуры:

На Паскале:

program prog;

var

   a:array[1..20] of integer;

   i,c:integer;

begin

   c:=0;

   for i:=1 to 20 do begin

       write('Введите температуру ', i, '-го дня: '); readln(a[i]);

       if a[i]>3 then c:=c+1;

   end;

   write('Количество дней с температурой воздуха больше 3 градусов: ', c);

end.

На Питоне:

c = 0

a = [int(input(f'Введите температуру {i+1}-го дня: ')) for i in range(20)]

print(a)

for i in a:

   if i > 3: c+=1

print(f'Количество дней с температурой воздуха больше 3 градусов: {c}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота