В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите метод который:
- принимает параметром массив целых чисел;
- выбирает случайным образом одно число из массива;
- находит крайнее правое и крайнее левое вхождение этого числа в
массив;
- возвращает «размах» , т.е. количество элементов между крайними
вхождениями
(включая сами вхождения);
- если вхождение единственное, то вернуть 1.

Я вроде бы написал,но всё равно пишет ошибка

public class Task5 {
public static int xxx(int[] i){
Random r = new Random();
int x = i.length;
int left = x;
for(int b = x - 1; b >= 0; b--){
if(i[b] == i[x]){
left = b;
}
}
int right = x;
for(int b = x + 1; b < i.length; b++){
if(i[b] == i[x]){
right = b;
}
}
int a = left == right ? 1 : right - left;
return a;
}
}

Показать ответ
Ответ:
лаьтслчлвт
лаьтслчлвт
12.05.2021 03:44

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   setlocale(LC_ALL, "RU");

   int N;

   cin >> N;//массив на N элементов

   vector<int>a;

   for (int i = 0; i < N; i++)

       a.push_back(rand()%100);// заполнение массива числами от 0 до 100

   for (int i = 0; i < N; i++)

       cout << a[i] << " ";

   cout << endl;

   bool flag=false;

   int number;

   for (int i = 0; i < N; i++) {

       auto r = find(a.begin(), a.end(),a[i]);// функция стандартной библиотеки для поиска

       if (r != a.end()&&r-a.begin()!=i)

       {

           number = r - a.begin();// номер элемента массива с одинаковым значением

           flag = true;

           break;

       }

   }

   if (flag)

       cout <<"В массиве присутствуют элементы с одинаковыми значениями. Одним из равных значений является: "<<a[number];

   else

       cout << "В массиве не присутствуют элементы с одинаковыми значениями";

}

0,0(0 оценок)
Ответ:
Поэзия
Поэзия
17.06.2022 13:57

<-------------------------1------------------------->

#include <iostream>

#define _USE_MATH_DEFINES

#include <math.h>

using namespace std;

int main()

{

  setlocale(LC_ALL, "RU");

  double  PI = M_PI;

  double r, R;

  cin >> r >> R;// сначала вводится внутренний радиус

  cout <<"S= "<<PI*(R*R-r*r)<<"= PI*"<< (R * R - r * r);

  return 0;

}

<-------------------------2------------------------->

#include <iostream>

using namespace std;

int main()

{

  setlocale(LC_ALL, "RU");

  double x, y;

  cin >> x >> y;//

  if (y==(5*x*x-7*x+2))

   cout << "ДА";

  else

   cout << "НЕТ";

  return 0;

}


(C++) Найти площадь кольца,внутренний радиус которого равенr1,а внешний r2Составьте программу,опреде
(C++) Найти площадь кольца,внутренний радиус которого равенr1,а внешний r2Составьте программу,опреде
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота