В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
samira2314
samira2314
18.11.2022 12:01 •  Информатика

Напишите мне данное от program до end. (тема "циклы"- pascal abc) написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5, количество суммированных членов ряда задаётся во время работы программы. ниже примерно рекомендуемый вид экрана во время работы программы. вычисление частичной суммы ряда: 1,3,5, введите количество суммированных членов ряда -> 1-5 сумма первых 15 членов ряда равна 330.

Показать ответ
Ответ:
hameleon5
hameleon5
29.07.2020 11:53
Program zhn;
var
  i,n,sum:integer;
begin
  writeln('Вчисление суммы членов последовательности: 1,3,5,7...');
  write('Введите количество членов для сложения:');
  readln(n);
  for i:=1 to n*2 do begin
    if i mod 2 <> 0 then sum:=sum+i; //Проверяем что бы число было нечетным
  end;
  writeln('Сумма ',n,' членов прогресии = ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота