В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
leonde
leonde
02.12.2022 12:30 •  Информатика

напишите на каком языке программировали: E. Числа Армстронга
Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Натуральное десятичное N-значное число называется числом Армстронга, если сумма его цифр, возведенных в степень N, равна самому числу.

Примеры:

153 = 13 + 53 + 33

1634 = 14 + 64 + 34 + 44

Напишите программу, которая находит все числа Армстронга на отрезке [a , b] .

Формат ввода
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что 1 ≤ a ≤ b ≤ 106 .

Формат вывода
Программа должна вывести в одну строчку все числа Армстронга на отрезке [a , b] , разделив их пробелами. Если таких чисел нет, программа должна вывести число -1

Пример 1
Ввод Вывод
100 400
153 370 371
Пример 2
Ввод Вывод
500 600
-1

Показать ответ
Ответ:
Smartfone
Smartfone
25.11.2022 20:33

ЯП: С++

#include <iostream>

int main() {

const int N = 5;

int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5

for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;

{

 for (int j = 0; j < N; j++)

 {

  std::cout << arr[i][j] << "\t";

 }

 std::cout << std::endl;

}

std::cout << "Result #1: ";

for (int i = 0; i < N; i++) // вывод в консоль главной диагонали

{

 std::cout << arr[i][i] << "\t";

}

std::cout << "\nResult #2: ";

for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали

{

 std::cout << arr[i][N - 1 - i] << "\t";

}

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
nastya02012007
nastya02012007
21.03.2023 15:35

Объяснение:

Если и считать всё в двоичной системе, то надо сначала все числа перевести в неё.

Перевод из шестнадцатеричной в двоичную- каждая шестнадцатеричная цифра заменяется на четыре двоичных, затем незначащие нули спереди- отбрасываются:

10₁₆ = 00010000₂ = 10000₂

Перевод из восьмеричной в двоичную- каждая восьмеричная цифра заменяется на три двоичных, затем незначащие нули спереди- отбрасываются:

10₈ = 001000₂ = 1000₂

Получаем в итоге пример:

10000₂ + 1000₂ + 10₂* 10000₂ = 10000₂ + 1000₂ + 100000₂ =

= 111000₂

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота