В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gravasamp
gravasamp
08.04.2023 14:16 •  Информатика

Напишите на паскале программу, которая запрашивает с клавиатуры массив из n чисел, а затем выводит среднее арифметическое всех элементов массива.

Показать ответ
Ответ:
отличник737
отличник737
02.10.2020 09:28
Var n, i, sum: integer;
a: array[1..100] of integer;
average: real;
begin
write('Сколько чисел будет в массиве? ');
readln(n);
sum := 0;
for i := 1 to n do
begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;
average := sum/n;
writeln('Среднее арифметическое: ', average);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота