В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
albinka2017
albinka2017
15.06.2022 15:19 •  Информатика

, напишите на с++.Желательно с использованием процедур. Без динамических массивов Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.

Входные данные
Входная строка содержит целое число N .

Выходные данные
Программа должна вывести двоичное представление переданного её числа.

Показать ответ
Ответ:
резной777
резной777
15.01.2023 01:32
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

function MaxSubstr(s1,s2:string):string;
begin
  var a:=new integer[s1.Length+1,s2.Length+1];
  var u:=0; var v:=0;
  for var i:=0 to s1.Length-1 do
    for var j:=0 to s2.Length-1 do
      if s1[i+1]=s2[j+1] then begin
        a[i+1,j+1]:=a[i,j]+1;
        if a[i+1,j+1]>a[u,v] then begin u:=i+1; v:=j+1 end
        end;
  Result:=s1.Substring(u-a[u,v],a[u,v])
end;

begin
  var s:='trapperkaperkatrter';
  var t:='appekaperspamer';
  Writeln(MaxSubstr(s,t))
end.
0,0(0 оценок)
Ответ:
doge232
doge232
16.03.2020 20:01
Var a:array[1..100,1..100] of integer; i,j,n,m,max,min:integer; begin write ('Введите количество строк: '); read(n); writeln; write ('Введите количество элементов в строке: '); read(m); writeln; writeln('Введите массив: '); for i:=1 to n do begin for j:=1 to m do begin write(' a[',i,',',j,']='); read(a[i,j]); end; writeln; end; writeln; writeln('Исходный массив: '); for i:=1 to n do begin for j:=1 to m do write(a[i,j],' '); writeln; end; writeln; writeln('Конечный массив: '); for i:=1 to n do begin min:=a[i,1]; max:=a[i,1]; for j:=2 to m do begin if (min>a[i,j]) then min:=a[i,j]; if (max
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота