Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
algebraigeometria1
29.03.2020 15:48 •
Информатика
Напишите на языке с и с++ программу, которая бы пользователя, справшивала его имя и год рождения и вычисляла бы количество полных лет. пожвлуйста,
Показать ответ
Ответ:
Дінислам
06.10.2020 00:14
C:
#include <stdio.h>
int main()
{
char name[10];
int year;
printf("Введите Ваше имя: ");
scanf("%s",&name);
printf("Здравствуйте, %s\n",name);
printf("Введите год рождения: ");
scanf("%d",&year);
printf("Вам %d лет\n", 2017-year);
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
C++
#include <iostream>
#include <string>
using namespace std;
int main()
{
string name;
int year;
cout << "Введите Ваше имя: ";
getline (cin, name);
cout << "Здравствуйте, " << name << endl;
cout << "Введите год рождения: ";
cin >> year;
cout << "Вам " << 2017-year << " лет" << endl;
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
0,0
(0 оценок)
Популярные вопросы: Информатика
nastyadolbakp0837c
05.03.2020 17:39
Построить таблицу истинности с указанием алгоритма: (avb)& (a-vb)p.s: минус с сверху a...
2004by2013
08.02.2021 00:55
Укажите какие числа записаны с ошибкой. 123(7), 3005(4), 12аас09(20), 13476(7)....
Хэймзон
23.09.2021 01:44
Kiss после загрузки изображения показанный напишите ответ соответствующая числу...
DamirKa1111
08.02.2022 07:41
Основную часть окна графического редактора занимает? 5 букв я хз !...
Оля2204202
05.10.2021 21:44
1.В алгоритме записанном ниже, используются действительные переменные х. у. Определите значение переменной у после исполнения данного алгоритма: 1. В алгоритме. y:=6; x:=y/2;...
Irakli2007
14.10.2022 00:19
Решить. верно ли утверждение: 1) квадрат со стороной а является описанным около окружности радиуса r. 2) дано двузначное число: a) в него входит цифра 3; b) в него входят цифры...
mashenkalarchenko
04.02.2021 03:59
нужно число и как нашли ответ...
oksana1382
14.04.2023 01:37
Написать решение пяти задач. Вывести массив из 15 элементов, заполненный по следующему правилу: 1) 1, 2, 3, 4, … , 15 2) 2, 4, 6, 8, … 3) 1, 3, 5, 7, … 4) 7, 14, 21, 28, … 5)...
муза2007
18.05.2023 08:35
С ИНФОРМАТИКОЙ перевести двоичную в десятичную и обратно 10110 110111 89 361...
ivanivankuznets
24.01.2021 18:03
Информационный объем сообщения о том, что продан последний билет на сеанс кино, содержит 6 бит. Сколько максимально могли продать билетов на данный сеанс?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <stdio.h>
int main()
{
char name[10];
int year;
printf("Введите Ваше имя: ");
scanf("%s",&name);
printf("Здравствуйте, %s\n",name);
printf("Введите год рождения: ");
scanf("%d",&year);
printf("Вам %d лет\n", 2017-year);
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
C++
#include <iostream>
#include <string>
using namespace std;
int main()
{
string name;
int year;
cout << "Введите Ваше имя: ";
getline (cin, name);
cout << "Здравствуйте, " << name << endl;
cout << "Введите год рождения: ";
cin >> year;
cout << "Вам " << 2017-year << " лет" << endl;
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет