Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Lybava13322131
05.08.2020 06:21 •
Информатика
Напишите подпрограмму которая возвращает минимальное и максимальное значение из двух целых чисел a и b при следующих формул. min(a,b)=a+b-(a-b)/2 max(a,b)=a+b+(a-b)/2
Показать ответ
Ответ:
ОленкаБурковська
24.09.2020 07:28
Var a,b:integer;
procedure min(x,y:integer);
begin
writeln(x+y-(x-y)/2);
end;
procedure max(x,y:integer);
begin
writeln(x+y+(x-y)/2);
end;
begin
writeln('Введите A,B');
readln(a,b);
write('min(',a,',',b,') = '); min(a,b);
write('max(',a,',',b,') = '); max(a,b);
end.
Тестовое решение:
Введите A,B
5 8
min(5,8) = 14.5
max(5,8) = 11.5
Введите A,B
9 4
min(9,4) = 10.5
max(9,4) = 15.5
0,0
(0 оценок)
Популярные вопросы: Информатика
таня1966
21.04.2020 03:33
1)постройте прямой код для числа 126. ответ запишите в шестнадцатеричном виде. 2)рассматривается 8-разрядная арифметика со знаком (используя дополнительный код). запишите число -28...
12235110spl
05.08.2021 22:02
Сколько единиц в двоичной записи числа 237?...
Fgbjhjghhy1234567890
19.07.2021 03:21
Записать на паскале даны два числа х, у большее из них возвести в квадрат....
zachar3
09.06.2020 11:35
Решить : 1. полный путь файлу: c: \books\raskaz.txt. каково собственно имя файла? 2. в некотором каталоге хранился файл дневник.txt. после того, как в этом каталоге создали подкаталог...
Skripp
11.02.2022 09:35
Что входит в аппаратное обеспечение компьютера...
Qulya11
26.02.2022 04:49
Число 745 перевести из 10 системы счисления в 2...
kiryazhigulski
26.02.2022 04:49
Укажите отношение для пары процессор и системный блок : 1.является элементом множества 2.входит в состав 3.является разновидностью 4.является причиной...
Инга1702
26.02.2022 04:49
Информатика 9 класс. турбо паскаль.дано три целых числа.найти произведение максимального на минимальное. нужно составить формулу. : (...
zeus333
21.11.2020 00:24
Решить пример 1011+111 = ? ! заранее всем ! я имела в виду в сфере программирования....
Ника260406
23.09.2020 10:39
Одно из сторон прямоугольник в 1,5 раза больше другой. найдите стороны прямоугольника, если его периметр равен 200 см....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
procedure min(x,y:integer);
begin
writeln(x+y-(x-y)/2);
end;
procedure max(x,y:integer);
begin
writeln(x+y+(x-y)/2);
end;
begin
writeln('Введите A,B');
readln(a,b);
write('min(',a,',',b,') = '); min(a,b);
write('max(',a,',',b,') = '); max(a,b);
end.
Тестовое решение:
Введите A,B
5 8
min(5,8) = 14.5
max(5,8) = 11.5
Введите A,B
9 4
min(9,4) = 10.5
max(9,4) = 15.5