В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
еьпа
еьпа
04.12.2020 07:27 •  Информатика

Напишите программу. даденое число х. когда число чётное, то нарисовать на экране зелёный прямоугольник, а когда не чётное, то красный круг

Показать ответ
Ответ:
Клубничка0987654322
Клубничка0987654322
19.02.2020 16:37
Var
 ar,ar2:array[1..10] of integer;
 i:integer;
begin
randomize;
 writeln('First array:');
  for i:=1 to 10 do
   begin;
    ar[i]:=random(10)-3;
    write(ar[i]:4);
    if ar[i]=0 then ar2[i]:=0;
   end;
 writeln;
 writeln('1-st Final array:');
  for i:=1 to 10 do
   begin;
    write(ar2[i]:4);
    if ar[i]<0 then ar2[i]:=ar[i];
   end;
 writeln;
 writeln('2-st Final array:');
  for i:=1 to 10 do
   begin;
    write(ar2[i]:4);
    if ar[i]>0 then ar2[i]:=ar[i];
   end;
 writeln;
 writeln('3-st Final array:');
  for i:=1 to 10 do
    write(ar2[i]:4);
end.    
0,0(0 оценок)
Ответ:
Dinomid93
Dinomid93
08.01.2021 15:35
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var x:=-2.0;
  while x<=2 do begin
    Writeln('x=',x:4:1,' y=',x*x*x+12:6:3);
    x+=0.2
    end
end.

Результат выполнения программы:
x=-2.0 y= 4.000
x=-1.8 y= 6.168
x=-1.6 y= 7.904
x=-1.4 y= 9.256
x=-1.2 y=10.272
x=-1.0 y=11.000
x=-0.8 y=11.488
x=-0.6 y=11.784
x=-0.4 y=11.936
x=-0.2 y=11.992
x= 0.0 y=12.000
x= 0.2 y=12.008
x= 0.4 y=12.064
x= 0.6 y=12.216
x= 0.8 y=12.512
x= 1.0 y=13.000
x= 1.2 y=13.728
x= 1.4 y=14.744
x= 1.6 y=16.096
x= 1.8 y=17.832
x= 2.0 y=20.000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота