В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Яся83
Яся83
24.09.2021 18:38 •  Информатика

Напишите программу )) дан массив действительных чисел.среди них есть равные .найти первый максимальный элемент массива и заменить его нулём

Показать ответ
Ответ:
kristinka127
kristinka127
24.05.2020 06:53

Program num1;
Uses crt;
Var x:array[1..10] of real;
max:real;
i : integer;
Begin
clrscr;
for i:=1 to 10 do
begin
write('x[',i,']=');readln(x[i])
end;
max:=x[1];
for i:=1 to 10 do
if x[i]>=max then max:=x[i];
Writeln('Max=',max:3:1);
for i:=1 to 10 do
if x[i]=max then begin x[i]:=0;break end;
for i:=1 to 10 do write(' *',x[i]:3:1,'* ');
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота