В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SanyaLe9
SanyaLe9
04.05.2021 16:18 •  Информатика

Напишите программу для движения геометрической фигуры по оси Х. Фигура появляется с левой стороны, доходит до правой и исчезает

Показать ответ
Ответ:
Danil24052002
Danil24052002
14.11.2022 22:19
Program a1; // a1 - название твоей проги, с задают название программы.
var a,b,c, s : integer; // a, b, c, s - переменные. var — ключевое слово, после этого слова объявляют переменные.
begin // begin и end — это как скобки, в которых ты решаешь выражение
readln(a);
readln(b);
readln(c);
// readln() — оператор, с которого можно отправлять данные в компьютер. Есть и такая fорма записи. read(). Отличие read от readln в том, если использует второй вариант readln(), то каретка( _) переносится на новую строку.
s := b*2-4*a*a; // присваиваем значения переменных в переменную s.
if (s > 0) then // конструкция if else позволяет проверять условия, если это равно или не равно, то делай компьютер другое...
 writeln(' Число положительное');
else if (s  <  0) then
 writeln(' Число отрицательное');
// writeln() выводит инfу на экран.
end.
0,0(0 оценок)
Ответ:
Winstorm
Winstorm
04.09.2022 05:10
Var
A:array[1..1000,1..1000] of integer;
M,N,Min,Max:integer;
Begin
Write('M(1..1000) = ');
ReadLn(M);
Write('N(1..1000) = ');
ReadLn(N);
For var i:= 1 to M do
    Begin
    For var j:= 1 to N do
        Begin
        A[i,j]:=random(1,M*N);
        Write(A[i,j],' ')
        End;
    WriteLn;
    End;
Min:=A[M,N];
Max:=A[M,N];
For var i:= 1 to M do
    For var j:= 1 to N do
        Begin
        if Min>A[i,j] then Min:=A[i,j];
        if Max<A[i,j] then Max:=A[i,j]
        End;
WriteLn('Min(A) / Max(A) = ',Min/Max);
End.

Пример:

M(1..1000) = 3
N(1..1000) = 3
6 9 6
4 5 3
1 9 7
Min(A) / Max(A) = 0.111111111111111
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота