Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
knowyourway54
04.06.2022 01:47 •
Информатика
Напишите программу для паскаля: для нахождения делителей числа n и их суммы с цикла while
Показать ответ
Ответ:
Supermatematik1245
02.07.2020 14:48
Program s;
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Selektro
19.09.2020 10:00
Часы на питоне используя циклы...
pavelakur
18.02.2023 14:02
Дайте определение основным составляющим блок-схемы:...
akakkakksksak
17.09.2021 06:28
составить код на языке программирование СИ: Задана матрица целых чисел. Найти номер строки с наименьшим номером, где есть числа, в которых только три делителя. Введение элементов...
Лина14881
10.10.2022 02:17
После преобразования растрового графического файла его объём уменьшился в 2 раза. сколько цветов было в палитре первоначально, если после преобразования было получено растровое...
arinalomova13
25.04.2021 11:10
Кто, когда и где разработал первый проект автоматической вычислительной машины...
tikmehr
06.07.2022 19:19
Выполнение основных алгоритмов работы в операционной системе. подскажите сайт , искала сама, ничего не нашла...
ЮлияБогинская
06.07.2022 19:19
1) в программе описан одномерный целочисленный массив с индексами от 0 до 10. в ниже фрагменте программы массив сначала заполняется, а потом изменяется: for i: =0 to 10 do...
cernyshova
06.07.2022 19:19
Синформатикой, 1) организовать ввод своей фамилии, имени, отчества в трех строковых переменных. при склейки получить новую переменную (из трех введенных) и найти длину этой...
v201612
22.02.2022 19:18
Напишите подпрограмму которая рисует домик...
Xidirova04
22.02.2022 19:18
Область где происходит дейсивие над обьектами...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.