В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Chcdhj
Chcdhj
18.04.2020 15:07 •  Информатика

Напишите программу для подсчета количества отрицательных элементов в целочисленном массиве из 30 элементов, заполненных случайными числами в интервале [-50; 50]. Если в массиве нет отрицательных элементов, программа должна сообщать об этом

Показать ответ
Ответ:
Мюсли004
Мюсли004
05.10.2020 08:14
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Ответ:
1 - моделью
2 - меньше информации
3 - глобус, макет здания, муляж яблока, манекен
4 - рисунок, фотография
5 - знаковой
6 - смешанной
7 - автомобиль — техническое описание автомобиля, город — путеводитель по городу
8 - существенные признаки объекта-оригинала
9 - разные модели объекта
10 - физическая карта, график зависимости расстояния от времени, схема узора для вязания крючком, схема метро
11 - словесное описание, формула
12 - знаковой
13 - смешанной
14 - болт — чертеж болта, мелодия — нотная запись мелодии
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота