В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mavlud111
mavlud111
19.02.2022 22:13 •  Информатика

Напишите программу для решения : дано целое неотрицательное число. определить количество нулей в его десятичной записи, на до на паскале, ! заранее .

Показать ответ
Ответ:
dasha12328
dasha12328
15.06.2020 02:46

Program noli;

Var X, Y: integer;

Begin

S:=0;

Write ('Введите число Х');

Read (X);

While X<>0 do begin

Y:= X mod 10;

If Y = 0 then S:= S + 1;

X:= X div 10;

Write ('Количество нулей в числе', S);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота