В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Arina111933
Arina111933
26.05.2022 10:00 •  Информатика

Напишите программу для решения квадратных неравенств на языке pascal. ax^2 + bx +c (< ; ≤; > ; ≥) 0 нужна ! заоанее ​

Показать ответ
Ответ:
nika032009003
nika032009003
04.08.2022 08:30
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!

function IsPrime(Self:integer):boolean; extensionmethod;
begin
  var n:=Self;
  if n<4 then Result:=True
  else begin
    var found:=(n mod 2=0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin found:=(n mod p=0); p+=2 end;
    Result:=not found
    end
end;

function Digits(Self:integer):integer; extensionmethod;
begin
  Result:=Self.ToString.Length
end;

begin
  var x:=ReadSeqIntegerWhile('Окончание ввода 0'+NewLine,p->p<>0).ToArray;
  var y:=x.Where(y->(y.Digits<=5) and y.IsPrime).ToArray;
  var s:=y.Select((p,i)->(p,i)).OrderBy(p->p[0]);
  var h:=(s.Take(3)+s.TakeLast(2)).Select(p->p[0]).ToHashSet;
  y:=y.Where(p->not (p in h)).ToArray;
  Writeln('- '*25); y.Println
end.

Пример
Окончание ввода 0
 3191 10853 769 683 81 52 653 85781 1 7937 67 316109 767071 98227 7811 283 84 593 976307 815292 31 53 96269 50881 5760 2 9371 7963 50539 2887 370 9973 918 23 2153 2637 183301 11 93563 21499 67967 694 817 990805 86287 805517 55837 307 87251 111919 37 719 4988 89 46727 575581 54042 97847 177 4817 16357 509 89057 4 8219 17623 35 937 3 5 81916 23633 2728 1069 991 122599 61 383 789088 80 614254 1266 72221 143337 195733 491 1831 12781 551093 494563 9316 9721 1483 2815 409 837812 17 41 419 9 13 32533 50329 408 43 768127 317491 631 90702 74005 310087 77893 16356 43451 36017 7 6706 755863 411 551875 595024 681 384049 85933 841968 83 7879 688697 23459 107 47194 257 38 0
- - - - - - - - - - - - - - - - - - - - - - - - -
3191 10853 769 683 653 85781 7937 67 283 593 31 53 96269 9371 7963 50539 2887 9973 23 2153 11 93563 21499 67967 86287 55837 307 87251 37 719 89 46727 4817 509 89057 8219 17623 937 5 23633 1069 991 61 383 72221 491 1831 12781 9721 1483 409 17 41 419 13 32533 50329 43 631 77893 43451 36017 7 85933 83 7879 23459 107 257
0,0(0 оценок)
Ответ:
pandapurple
pandapurple
15.04.2021 20:25
1. Для ввода формулы в ячейку С5 необходимо:
выбрать (щелкнуть один раз) в 5 строку и 3 столбец и нажать =
после = можно вводить формулу
2.Как можно отменить неверную операцию, если Вы ошиблись?
сочетанием клавиш Ctrl + z
3.Какой знак не может быть использован в качестве оператора в формуле?
В формуле можно использовать любые арифметические операторы: сложение (+), вычитание (-), умножение (*), деление (/), вычисление процентов (%) или возведение в степень (^). Логические операторы: равно (=), больше (>), меньше (<), больше или равно (>=), меньше или равно (<=), не равно (<>). & используется для соединения текстовых строк. Можно использовать скобки. Можно использовать буквы - для указания ссылки на ячейку (н-р, B2) или диапазон (A1:A10).
А какой не может быть использован - не знаю. Остаются: ? " ' @ !
4.Клавишу Enter в MS Word необходимо нажимать:
чтобы закончить абзац
5.К чему приводит нажатие на клавиатуре клавиши Delete?
удалить символ справа от курсора (следующий за курсором)
6.После ввода формулы в ячейку в ней появилась последовательность символов . Какое и нижеследующих действий Вы должны выполнить?
расширить столбец или проверить не отрицательное ли значение даты и времени (если там дата или время)
7.Для перемещения курсора по рабочему полю можно использовать клавиши:
стрелку вправо, стрелку влево, стрелку вверх, стрелку вниз, кнопки: Home, End, Page Up, Page Down
всё вышеперечисленное можно использовать в сочетании с Ctrl, н-р, Ctrl + End чтобы перейти в самый конец 
8.С какого символа начинается формула в Excel?
со знака =
9.Программа Excel используется для...
Используется для работы с электронными таблицами
10.Можно ли удалить неверно набранный символ?
можно, клавишами Backspace и Delete
11.В каких единицах устанавливается размер шрифта?
в пунктах (пт)
12.Что Вы видите в строке формул?
формулу: операторы и ссылки на значения в ячейках
13. Как скопировать фрагмент текста с мыши?
правой кнопкой вызвать контекстное меню и  выбрать копировать
14.Какая причина могла привести к появлению в ячейке #ЗНАЧ!?
формула содержит недопустимый тип, н-р, когда пытаешься умножить текст
15.Каким можно быстро перейти в начало документа?
сочетанием Ctrl + Home
16.Какие данные из перечисленного не могут быть содержимым ячейки?
... (нет перечисленного)
17.Для какой цели может использоваться команда Файл Сохранить как?
сохранить файл в другом формате или сохранить копию файла 
18.Что обозначает А1:ВЗ?
диапазон ячеек начиная с А1 и до B3
19.Какое расширение из приведенных имеют файлы в Excel
последние версии Excel: xlsx, xlsm
20.Какие клавиши клавиатуры можно нажать для разделения одного абзаца на два?
Enter, Ctrl + Enter
21.Как наиболее эффективно удалить содержимое трех больших несвязанных диапазонов?
выделить первый диапазон, нажать сочетание Shift + F8 и выделить два остальных диапазона. Нажать Delete.
Чтобы быстро выделить большой диапазон можно использовать сочетания: Ctrl+Shift+стрелку в нужную сторону (выделит с первой ячейки до последней непустой) или ctrl+A (выделить диапазон вокруг выбранной ячейки до непустых ячеек)
22.В какой из формул допущена ошибка?
... (нет формул)
23.Па основе чего строится любая диаграмма?
данные из таблицы
24.Можно ли изменить параметры диаграммы после ее построения?
да, выбрать в меню: изменить данные
25.Какой из указанных методов редактирования ячейки является неправильным?
... (нет указаний)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота