В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DenQ04a
DenQ04a
04.05.2020 23:50 •  Информатика

Напишите программу для решения предложенной задачи, наберите и отладьте ее. Файл с программой пришлите учителю на почту. (для решения задачи потребуются арифметические операции div - целочисленное деление и mod - остаток от целочисленного деления)
Составьте программу, которая для числа K (от 1 до 99), введенного вами, напечатает фразу «Мне K лет», где K – введенное число, при этом в нужных случаях слово «лет» заменяя на «год» или «года». Например, при K=70 «Мне 70 лет», при K=15 «Мне 15 лет», при K=23 «Мне 23 года», при K=31 «Мне 31 год». и.тп

Показать ответ
Ответ:
vulf20
vulf20
04.04.2023 20:58

ответ:

объяснение:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

const n=23; m=40; //n-ряды, m-места

var

  a: array[1..n,1..m] of integer; //зрительный зал

  i,j,k: integer;

begin

  randomize;

  writeln('зрительный зал: ');

  write('м/р');

  for i: =1 to m do write(i: 3);

  writeln;

  for i: =1 to n do begin

    write(i: 3);

    for j: =1 to m do begin

      a[i,j]: =ord(random(10)> 0); write(a[i,j]: 3); //read(a[i,j]); я ввожу гадалкой, т.к. руками вбивать 920 цифирь не входит в мое понятие героизма

    end;

    writeln;

  end;

  repeat

    write('в каком ряду смотреть свободные места? ');

    readln(i);

  until (i> 0) and (i

  k: =0;

  for j: =1 to m do k: =k+ord(a[i,j]=0); //cчитаем свободные места

  write('в ряду ',i);

  if k> 0 then writeln(' есть свободные места в количестве ',k,' шт.') else

  writeln(' свободных мест нет');

end.

0,0(0 оценок)
Ответ:
linaaalinaa
linaaalinaa
26.01.2021 04:32

ответ:

uses crt;

var a: array[1..20,1..20] of real;

    n,m,i,j: integer;

    s: real;

begin

    clrscr; randomize;

    write('введите кол-во строк: '); readln(n);

    write('введите кол-во столбцов: '); readln(m);

    for i: =1 to n do

    begin

      for j: =1 to m do

      begin

        a[i,j]: =random(100)/10;

        write(a[i,j]: 4: 1);

      end;

      writeln;

    end;

    for i: =1 to n do

    begin

      s: =0;

      for j: =1 to m do

      s: =s+a[i,j];

      writeln('сумма ',i,'-ой строки: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      for i: =1 to n do

      s: =s+a[i,j];

      writeln('сумма ',j,'-ого столбца: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      if j mod 2 = 0 then  

      begin

        for i: =1 to n do

        s: =s+a[i,j];

        writeln('среднее арифметическое ',j,'-ого столбца: ',s/m: 0: 1);

      end;

    end;

    readln;

end.

объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота