В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
krivobokova45
krivobokova45
16.10.2021 19:50 •  Информатика

Напишите программу для решения следующей .
ученики 4 класса вели дневники наблюдения за погодой и ежедневно
записывали дневную температуру. найдите среднюю температуру для дней,
когда столбик термометра поднимался выше нуля градусов. определите
количество таких дней. гарантируется, что за время наблюдения хотя бы
в один из дней температура поднималась выше нуля градусов.
программа получает на вход количество дней, в течение которых
проводилось наблюдение n (1 ≤ n ≤ 31), затем для каждого дня вводится
температура. python!

Показать ответ
Ответ:
pro22896
pro22896
01.10.2019 22:20
Var a: array[1..31]of integer;
n,s,i,k: integer;
begin
s: =0;
k: =0;
writeln(введите кол-во дней);
readln(n);
for i: =1 to n do
begin
readln(a[i]);
s: =s+a[i];
if a[i]> 0 then k: =k+1;
end;
s: =s/n;
writeln(средняя температура,s);
if k> =5 then writeln(yes) else writeln(no);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота