В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
polycov200412
polycov200412
02.11.2021 21:41 •  Информатика

Напишите программу для решения задач. Используйте операции div и mod. 3. Дана масса в граммах. Переведите ее в килограммы и
граммы.

Показать ответ
Ответ:
RIP12548
RIP12548
03.06.2022 01:47
В последней задаче понадобятся переводные коэффициенты.
1 берковец=10 пудов=400 фунтов=38400 золотников.
Отсюда:
1 фунт = 38400/400 = 96 золотников
1 пуд = 400/10 = 40 фунтов
1 берковец = 10 пудов

№1

var
  n:integer;
 
begin
  Write('Введите двухзначное число: '); Read(n);
  n:=Abs(n); { убираем минус, если он есть }
  Writeln('Среднее арифметическое цифр числа: ',
    (n div 10 + n mod 10)/2)
end.

Пример
Введите двухзначное число: 43
Среднее арифметическое цифр числа: 3.5

№2

var
  n:integer;
 
begin
  Write('Введите двухзначное число: '); Read(n);
  n:=Abs(n); { убираем минус, если он есть }
  Writeln('Разность количества десятков и единиц равна ',n div 10 - n mod 10)
end.

Пример
Введите двухзначное число: 38
Разность количества десятков и единиц равна -5

№3

var
  a:real;
 
begin
  Write('Площадь, ар: '); Read(a);
  Writeln('Полных кв.км: ',Trunc(a/10000))
end.

Пример
Площадь, ар: 252123234
Полных кв.км: 25212

№4

const
  f=96; { фунт }
  p=40; { пуд }
  b=10; { берковец }

var
  z:longint;
  kb,kp,kf:integer;
 
begin
  Write('Введите вес в золотниках: '); Read(z);
  kf:=z div 96;
  z:=z mod 96;
  kp:=kf div 40;
  kf:=kf mod 40;
  kb:=kp div 10;
  kp:=kp mod 10;
  Writeln('Это составит ',kb,' берковцев, ',kp,' пудов, ',
      kf,' фунтов, ',z,' золотников')
end.

Пример
Введите вес в золотниках: 374252
Это составит 9 берковцев, 7 пудов, 18 фунтов, 44 золотников
0,0(0 оценок)
Ответ:
Вичка03
Вичка03
07.09.2021 07:36

Можно управлять чем-то вручную, а можно запрограммировать и надеяться, что все сработает как надо. В быту широко используется программное управление для выполнения стандартных операций. Например выбор режим стирки в стиральной машине. При выборе того или иного режима активируется соответствующая программа. Просто и удобно.

Точно также производится готовка в мультиварке. Но когда требуется сделать что-то, чего не учитывает программа, делать приходится вручную.

При всей универсальности программа не может учесть всего. Всегда приходится что-то корректировать. Поэтому на практике приходится прибегать к обоим методам. Особенно, когда ручное управление затруднено. Так происходит, например при управлении марсоходом. Радиосигнал идет довольно долго и просто "порулить" марсоходом с земли в реальном времени не получится. Приходится отправлять блок команд и принимать сигнал о их выполнении.

В общем, вручную безусловно лучше, но не всегда возможно.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота