В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pocemonpickachu
pocemonpickachu
10.03.2020 14:25 •  Информатика

Напишите программу для решения задачи : найти сумму отрицательных элементов массива , состоящего из 15 чисел , сформированного случайными числами из диапазона от -20 до 20 (включительно). Полную программу В Паскале (если можно ,то на компе в Паскале с выводом , фото . У меня ноут не поддерживает программу)

Показать ответ
Ответ:
otepovaaazan
otepovaaazan
08.12.2020 06:10

var

       a: array [1..15] of Integer;

       i, sum: Integer;

       

begin

       Randomize;

       sum := 0;

       

       for i := 1 to 15 do

               a[i] := Random (41) - 21;

       

       for i := 1 to 15 do

               if a[i] < 0 then

                       sum := sum + a[i];

               

       Write (sum)

end.        

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота