В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kirillan2
kirillan2
26.04.2021 03:01 •  Информатика

Напишите программу для того чтобы протестировать детей как они умеют считать? показывается пример они считают в паскале!

Показать ответ
Ответ:
sdaugel
sdaugel
02.08.2020 10:22
Var
   n, i, r, sum, s: integer;
  ms: array[1..100]of char;
begin
  randomize;
  n := random(3, 7);
  var ar := arrrandom(n, 1, 50);
  for i := 1 to n - 1 do
   begin
    r := random(1, 2);
     if(r = 1) then ms[i] := '+'
     else ms[i] := '-' end;
  s := ar[0];
  write(ar[0], ' ');
  for i := 1 to n - 1 do
   begin
    write(ms[i], ' ', ar[i], ' ');
    if(ms[i] = '+') then s := s + ar[i]
    else s := s - ar[i];
  end;
  write(' = ');
  read(sum);
  if(s = sum)
then
write('Правильно')
   else
write('Неправильно, правильный ответ : ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота