В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Йошино1
Йошино1
26.10.2022 06:25 •  Информатика

Напишите программу для вычисления чисел Фибоначчи, которая занимает как можно меньше строк. Но каждая функция должна быть в отдельной строке.

Показать ответ
Ответ:
мая96
мая96
17.04.2023 13:16
{Дан массив из 100 элементов (заполняется случайно). Найти сумму тех элементов массива, порядковые номера которых не совпадают со значением этого элемента.}var j,k,i:integer;sum:longint;R:Array[1..100] of integer;Beginfor i:=1 to 100 do beginR[i]:= random(95)-25;write(R[i]:3);if i <> R[i] then sum:= sum + R[i];end;writeln;writeln('сумму элементов массива = ',sum);end.
{Дан массив из 100 целых чисел (числа вводятся случайно). Найти максимальный элемент массива.}var k,i,max:integer;R:Array[1..100] of integer;Beginmax:=-25;for i:=1 to 100 do beginR[i]:= random(95)-25;write(R[i]:3);if R[i] > max then max:= R[i];end;writeln;writeln('максимальный элемент массива = ',max);end.
0,0(0 оценок)
Ответ:
DrYgAn8998
DrYgAn8998
16.06.2021 04:50
1)
var a,b,a1,b1:real;
var s,s1:real;
begin
WriteLn('Введите все катеты через пробел:');
Read(a,b,a1,b1);
s:=a/2*b;
s1:=a1/2*b1;
WriteLn(s);
WriteLn(s1);
if s = s1 then
WriteLn('Треугольники равновелики')
else if s>s1 then
WriteLn('Площадь первого треугольника больше на '+(s-s1))
else
WriteLn('Площадь второго треугольника больше на '+(s1-s));
end.

2)
var a,b:Integer;
var arr:array of char;
begin
arr:=ReadString().ToCharArray();
for var i:= 1 to 6 do
if(i<4) then
a+= strtoint(arr[i-1])
else
b+= strtoint(arr[i-1]);
if a=b then
WriteLn('Билет счастливый')
else
WriteLn('Билет не счастливый');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота