В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
алтуша9796
алтуша9796
13.04.2020 07:47 •  Информатика

Напишите программу для вычисления наименьшего из четырех чисел Для этого создайте функцию min4.
в питоне​

Показать ответ
Ответ:
05NARIMAN05
05NARIMAN05
12.05.2023 09:55
#include <iostream>
#include <math.h>
#include <cstdlib>
using namespace std;

int main()
{
   int position = 0;

    int i,j, ch,a,s;
    int* mass = NULL;
    cout << "Заданное число А: ";
    cin >> a;

    while (1)

    {
        cin >> ch;
        if (ch == 0) break;
        mass = (int*)realloc(mass, (position+1)*sizeof(int));
        mass[position] = ch;
        position++;

    }
    s=0;
    j=0;
    for (i=0;i<position;i++){
        if (((mass[i] > 0) && (mass[i+1] > 0)) || ((mass[i] < 0) && (mass[i+1] < 0)))
            j++;
        if (((mass[i] > 0) && (mass[i] < a)))
            s++;
    }

    cout << "Номер поседней пары: " << j << endl;
    cout << "Положительно и не больше А: " << s << endl;

    return 0;
}
0,0(0 оценок)
Ответ:
aigul841107gMailcom
aigul841107gMailcom
11.01.2020 15:38

Вы можете создать простую формулу для с суммы, вычитания, умножения и деления значений на вашем компьютере. Простые формулы всегда начинаются со знака равной(=),за которым следуют константы, которые являются числами и операторами вычислений, такими как "плюс"(+),"минус" (- ),"звездочка"*или "косая черта"(/)в начале.

В качестве примера рассмотрим простую формулу.

Выделите на листе ячейку, в которую необходимо ввести формулу.

Введите = (знак равенства), а затем константы и операторы (не более 8192 знаков), которые нужно использовать при вычислении.

В нашем примере введите =1+1.

Примечания:

Вместо ввода констант в формуле можно выбрать ячейки с нужными значениями и ввести операторы между ними.

В соответствии со стандартным порядком математических операций, умножение и деление выполняются до сложения и вычитания.

Нажмите клавишу ВВОД (Windows) или Return (Mac).

Рассмотрим другой вариант простой формулы. Введите =5+2*3 в другой ячейке и нажмите клавишу ВВОД или Return. Excel перемножит два последних числа и добавит первое число к результату умножения.

Использование автосуммирования

Для быстрого суммирования чисел в столбце или строке можно использовать кнопку "Автосумма". Выберите ячейку рядом с числами, которые необходимо сложить, нажмите кнопку Автосумма на вкладке Главная, а затем нажмите клавишу ВВОД (Windows) или Return (Mac).

Кнопка "Автосумма" на вкладке "Главная"

Когда вы нажимаете кнопку Автосумма, Excel автоматически вводит формулу для суммирования чисел (в которой используется функция СУММ).

Примечание: Также в ячейке можно ввести ALT+= (Windows) или ALT+ КОМАНДА += (Mac), и Excel автоматически вставит функцию СУММ.

Приведем пример. Чтобы сложить числа за январь в бюджете "Развлечения", выберите ячейку B7, которая непосредственно под столбцом чисел. Затем нажмите кнопку "Автоумма". Формула появится в ячейке B7, а Excel выделит ячейки, которые вы суммируете.

Формула, созданная нажатием кнопки «Автосумма» на вкладке «Главная»

Чтобы отобразить результат (95,94) в ячейке В7, нажмите клавишу ВВОД. Формула также отображается в строке формул вверху окна Excel.

Результат автосуммирования в ячейке В7

Примечания:

Чтобы сложить числа в столбце, выберите ячейку под последним числом в столбце. Чтобы сложить числа в строке, выберите первую ячейку справа.

Создав формулу один раз, ее можно копировать в другие ячейки, а не вводить снова и снова. Например, при копировании формулы из ячейки B7 в ячейку C7 формула в ячейке C7 автоматически настроится под новое расположение и подсчитает числа в ячейках C3:C6.

Кроме того, вы можете использовать функцию «Автосумма» сразу для нескольких ячеек. Например, можно выделить ячейки B7 и C7, нажать кнопку Автосумма и суммировать два столбца одновременно.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота