В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Eennoottt
Eennoottt
22.01.2020 07:50 •  Информатика

Напишите программу для вычисления степени k (целое) числа а (действительное). Для этого создайте функцию ​

Показать ответ
Ответ:
romafomin15рома
romafomin15рома
05.01.2021 21:27
Const
  nn=100;
var
  a:array[1..nn] of integer;
  i,n,s1,s2:integer;
begin
  Write('Введите размер массива n: '); Read(n);
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to n do begin
    a[i]:=Random(3000)+1000;
    Write(a[i]:5)
  end;
  Writeln;
  Writeln('Результаты');
  for i:=1 to n do begin
    s1:=(a[i] div 1000)+(a[i] div 100) mod 10;
    s2:=(a[i] div 10) mod 10+a[i] mod 10;
    if s1=s2 then Write(a[i]:5)
  end
end.

Тестовое решение:
Введите размер массива n: 50
Исходный массив
 3407 3373 2752 3121 2683 3082 3252 1364 3890 1595 3004 3206 3663 2523 1972 2003 2344 3901 3739 2898 1639 2839 2498 1200 1613 1498 1262 3370 1548 1287 1972 3348 1278 3116 1505 3235 1062 1740 2491 1023 3955 3704 1265 2567 1287 1255 2602 3924 2561 2912
Результаты
 3407 3663 2561
0,0(0 оценок)
Ответ:
kozaryk463
kozaryk463
14.11.2020 07:56
1. Размеры изображения даны в сантиметрах, а разрешающая сканера - в дюймах. Нужно перейти к каким-то одним единицам измерения, учитывая соотношение: 1 дюйм ≈ 2.54 см. Допустим, расчеты ведем в сантиметрах. По одной стороне изображения сканер распознает на длине в 1 дюйм (т.е. 2.54 см) 600 точек, по другой - 1200 точек. Тогда на 1 см длины придется 600/2.54 точек и 1200/254 точек соответственно. А на длине в 10 см - в 10 раз больше. Общее количество точек составит
\displaystyle \frac{600\times10}{2.54}\times \frac{1200\times10}{2.54}= \frac{72\cdot10^6}{2.54^2}\approx 11.16\cdot10^6
При глубине цвета два байта полученный графический файл будет иметь объем 11.16\cdot10^6\times2=22.32\cdot10^6 байт.
Можно перевести в мегабайты:
\displaystyle \frac{22.32\cdot10^6}{1024\times1024}\approx 21.3 Мбайт

2. Расчет аналогичный, поэтому можно писать кратко.
\displaystyle \frac{600\times15}{2.54}\times \frac{600\times10}{2.54}= \frac{54\cdot10^6}{2.54^2}\approx 8.37\cdot10^6 \\ 8.37\cdot10^6\times3=25.11\cdot10^6 \\ \displaystyle \frac{25.11\cdot10^6}{1024\times1024}\approx 23.95 Mb
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота