Напишите программу, используя цикл while, которая будет генерировать случайное число от 1 до 10 каждое повторение цикла. Добавьте счетчик повторений цикла, чтобы определить количество повторений до завершения цикла. Условие завершение цикла: случайно сгенерированное число равно 3. Задание 2.
Напишите программу, которая будет проверять правильность вводимых данных. В случае неправильного ввода, должна быть выведена ошибка ввода и предложение ввести данные снова.
программа пайтон
const n=10;
var a:array[1..n] of integer;
i,min,max:integer;
begin
for i:=1 to n do a[i]:=random(50);
for i:=1 to n do write(a[i]:4);
writeln;
min:=32000; max:=-32000;
for i:=1 to n do
if a[i]<min then min:=a[i];
for i:=1 to n do
if a[i]>max then max:=a[i];
writeln('минимальный элемент массива = ',min);
writeln('максимальный элемент массива= ',max);
end.
2.
const n=10;
var a:array[1..n] of integer;
i,j,p:integer;
begin
for i:=1 to n do a[i]:=random(20);
for i:=1 to n do write(a[i]:4);
writeln;
for i:=1 to n-1 do begin
for j:=1 to n-1 do
if a[j]<=a[j+1] then begin
p:=a[j]; a[j]:=a[j+1]; a[j+1]:=p;
end;
end;
for i:=1 to n do write(a[i]:4);
end.
//Версия 3.3, сборка 1634 (14.02.2018)
begin
var (cost, t, k) := (Arr(15, 70, 125, 230, 440), Arr(1, 5, 10, 20, 60), new integer[5]);
var n := ReadInteger('n->');
for var i := 4 downto 0 do
begin
k[i] := n div t[i];n := n mod t[i];
end;
if k[0] * cost[0] >= cost[1] then begin k[0] := 0;inc(k[1]); end;
if k[0] * cost[0] + k[1] * cost[1] >= cost[2] then
begin
k[0] := 0;k[1] := 0;inc(k[2]);
end;
if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] >= cost[3] then
begin
k[0] := 0;k[1] := 0;k[2] := 0;inc(k[3]);
end;
if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] + k[3] * cost[3] >= cost[4] then
begin
k[0] := 0;k[1] := 0;k[2] := 0;k[3] := 0;inc(k[4]);
end;
for var i := 0 to 4 do WritelnFormat('{0} билет(ов)- {1} штук(а)', t[i], k[i]);
end.
Пример(1):
n-> 37
1 билет(ов)- 0 штук(а)
5 билет(ов)- 0 штук(а)
10 билет(ов)- 0 штук(а)
20 билет(ов)- 0 штук(а)
60 билет(ов)- 1 штук(а)
Пример(2):
n-> 35
1 билет(ов)- 0 штук(а)
5 билет(ов)- 1 штук(а)
10 билет(ов)- 1 штук(а)
20 билет(ов)- 1 штук(а)
60 билет(ов)- 0 штук(а)