В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MaruaAvilova17
MaruaAvilova17
14.04.2023 08:04 •  Информатика

Напишите программу к вообще не понимаю! заранее ! поставлю ответ лучшим! шоколадка стоит a рублей с копеек. какое наибольшее количество шоколадок можно купить за b рублей?

Показать ответ
Ответ:
sharapoid
sharapoid
09.08.2020 23:59
Program program1;
var
a, b, c, n: integer;
begin
writeln('Введите стоимость шоколадки:');
write('рублей и копеек через пробел: ');
readln(a, c);
write('Введите количество рублей, которые имеются у Вас: ');
readln(b);
if (a < 0) or (c < 0) or (c > 99) then
writeln('введите корректные данные')
else
begin
n := trunc(b / (a + c/100));
writeln(n, ' шоколадок');
end;
end.
0,0(0 оценок)
Ответ:
ekaterinatrushkova
ekaterinatrushkova
09.08.2020 23:59
Var
  a,b,c:integer;
begin
  Write('Сколько стоит шоколадка (руб коп)? ');
  Read(a,c);
  Write('Сколько у вас рублей? ');
  Read(b);
  Write('Вы можете купить шоколадок: ',
    (100*b) div (100*a+c))
end.

Пример
Сколько стоит шоколадка (руб коп)? 35 50
Сколько у вас рублей? 140
Вы можете купить шоколадок: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота