В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
shulyakovatati
shulyakovatati
25.08.2020 00:42 •  Информатика

Напишите программу, которая анализирует, какую цифру нажал пользователь и вывести прописью название всех цифр, следующих за введенной. в остальных случаях вывести на экран - "это не цифра! ". напишите только тело программы, нужно сделать через switch и break

Показать ответ
Ответ:
incest
incest
09.10.2020 02:56

#include <iostream>

#include <cstdlib>

using namespace std;

void Output(void);

char numbers [10] [6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int digit;

int main()  

{  

cout << "Input digit: ";

cin >> digit;

 

switch(digit)

{

 case 0:

  Output();

  break;

 case 1:

  Output();

  break;

 case 2:

  Output();

  break;  

 case 3:

  Output();

  break;

 case 4:

  Output();

  break;

 case 5:

  Output();

  break;

 case 6:

  Output();

  break;

 case 7:

  Output();

  break;

 case 8:

  Output();

  break;

 case 9:

  cout << "No more digits";

  break;

 default:

  cout << "Input error! This is not a digit";

  return 1;

}

return 0;

}

void Output(void)

{

cout << "Next digits are ";

for (int i = digit + 1; i < 10; i++)

 cout << numbers [i] << " ";

}

// К сожалению, выравнивание текста и, если можно так выразиться, табуляция не везде корректно сохраняются, то сдвиги где-то отображаются, где-то нет. Поэтому прилагаю .cpp файл

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота