В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
karinabuchneva16
karinabuchneva16
15.07.2022 20:18 •  Информатика

Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина списка тоже должна быть случайной в диапазоне от
10 до 20. Потом программа должна найти в этом списке все элементы, меньшие
заданного пользователем значения, сформировать из них новый список и
напечатать первоначальный и полученный списки.Напишите программу на питоне

Показать ответ
Ответ:
clever113
clever113
26.08.2021 15:22

import random

list = []

numbers_range = random.randint(10, 20)

for i in range(numbers_range):

   numbers = random.randint(1, 100)

   i = numbers

   list.append(i)

user_number = int(input('Введите число: '))

user_list = []

for j in list:

   if j < user_number:

       user_list.append(j)

print(list)

print(user_list)

Объяснение:


Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота