В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
fiestrigha00p01bgj
fiestrigha00p01bgj
20.08.2020 04:11 •  Информатика

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и последний элемент.

Показать ответ
Ответ:
mashanlo2006
mashanlo2006
08.10.2020 20:38
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  for var i:=0 to a.RowCount-1 do begin
    var row:=a.Row(i);
    var imin:=row.IndexMin;
    Swap(row[imin],row[row.High]);
    a.SetRow(i,row)
    end;
  Writeln('*** Полученный массив ***'); a.Println(4)
end.

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и по
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота