В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kirillbatalov2
kirillbatalov2
22.12.2022 02:53 •  Информатика

Напишите программу, которая будет по 3 сторонам треугольника находить косинусы всех углов в радианах и градусах. у меня такое получилось, но он не привально вычисляет (сумма углов не равна 180 градусов).
program tc3c;
var a, b, c, d, e, f, g, j, i, k, l, m, n, o, p: double;
begin
read(a, b, c);
d: =a*a;
writeln ('a в квадрате=', d);
e: =b*b;
writeln ('b в квадрате=', e);
f: =c*c;
writeln ('c в квадрате=', f);
g: =(e+f-d)/(2*b*c);
j: =cos(g);
writeln ('cosa в радианах=', j);
n: =((180/pi)*j);
writeln ('первый угол в градусах=', n);
i: =(d+f-e)/(2*a*c);
k: =cos(i);
writeln ('cosb в радианах=', k);
o: =((180/pi)*k);
writeln ('второй угол в градусах=', o);
l: =(d+e-f)/(2*a*b);
m: =cos(l);
writeln ('cosc в радианах=', m);
p: =((180/pi)*m);
writeln ('третий угол в градусах=', p);
end.

Показать ответ
Ответ:
umnik84530
umnik84530
30.01.2022 20:46
1. "в одном килограмме 1000 грамм" - считая пробелы в этом предложении 29 символов - следовательно предложение вест 29 байт

2. 35-10=25 значений, 25 лежит в рамках от 17 до 32, следовательно одно значение будет весить 5 бит. так как 2^5=32. было 27 измерений - 5*27=135. ответ : объем всех результатов - 135 бит

3.  Одна лампа равна одному биту, так как можно представить, что включено - 1, выключено - 0. 
аналагично со второй задачей 200 лежит в рамках от 128(2 в седьмой степени) до 256(два в восьмой степени), значит для 200 разных сигналов потребуется 8 ламп
0,0(0 оценок)
Ответ:
2005лизок
2005лизок
11.06.2022 14:03
/*некритично, но у тебя нет диалога с пользователем. неплохо бы предложить ему ввести данные. в коде нет пояснений. 
*/
#include<iostream.h>
#include<conio.h>
#include<math.h> 
int main()

int b,a, x,y,z; 
cout<<"insert a"; cin>>a>>endl; 
cout<<"insert b"; cin>>b>>endl; 
cout<<"insert x"; cin>>x>>endl; 
//а что такое x, y,  и z - вообще непонятно. И откуда q появилась? ты ее не
//объявлял. 

if ((a%5==0)&&(b%5==0));
  {
if ((x<y)&&(y<z)) 
                   {y=a*x-b; cout<<"y="<<y<<endl; }
  if ((y<x)&&(y<z)) 
                   {y=a*y-b; cout<<"y="<<y<<endl; }
}
else cout<<"a i b ne kratny 5";
getch(); 
return 0;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота