В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
icidarmitrim
icidarmitrim
12.11.2020 07:22 •  Информатика

Напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. на c# .у кого есть ответы всех

Показать ответ
Ответ:
93angela93
93angela93
01.09.2021 12:37
//Pascal

//1)
var
  A: array [1..8] of integer;
  i: byte;
  sum: integer;
  Arifm: real;
begin
  writeln('Заполнение массива.');
  sum := 0;
  for i := 1 to 8 do
  begin
    write('A[',i,'] = ');
    readln(A[i]);
    sum := sum + A[i];
  end;
  Arifm := sum/8;
  writeln('Среднее арифметическое всех элементов = ', Arifm);
  writeln;
  writeln('Элементы меньше среднего арифметического.');
  for i := 1 to 8 do
    if A[i] < Arifm then
      write(A[i]:4);
  writeln; readln;       
end. 

//2)
var
  A: array [1..8] of integer;
  i: byte;
  sum: integer;
  Arifm: real;
begin
  writeln('Заполнение массива.');
  sum := 0;
  for i := 1 to 8 do
  begin
    write('A[',i,'] = ');
    readln(A[i]);
    if i mod 2 <> 0 then
      sum := sum + A[i];
  end;
  Arifm := sum/4;
  writeln('Среднее арифметическое элементов с нечетн. индексами = ', Arifm);
  readln;
end.

1.найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех эле
1.найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех эле
0,0(0 оценок)
Ответ:
варвара563536536
варвара563536536
04.07.2021 18:18
//Pascal
var
  A: array [1 .. 255, 1 .. 255] of integer;
  sumA, historyA: array [1 .. 255] of integer;
  i, j, n, m, z, count, count2: byte;
  tmpSum: integer;
begin
  randomize;
  write('Строк = '); readln(n);
  write('Столбцов = '); readln(m);
  for i := 1 to n do
  begin
    for j := 1 to m do
    begin
      A[i, j] := random(5);
      write(A[i, j]:4);
    end;
    writeln;
  end;
  writeln('---------------------------------------');
  for j := 1 to m do
  begin
    tmpSum := 0;
    count := 0;
    for i := 1 to n do
      tmpSum := tmpSum + A[i, j];
    sumA[j] := tmpSum;
  end;
  for i := 1 to m do
    write(sumA[i]:4);
  writeln; writeln;
  for j := 1 to m do
  begin
    count := 0;
    count2 := 0;
    tmpSum := sumA[j];
    for i := 1 to m do
    begin
      if (sumA[i] = tmpSum) then
        count := count + 1;
      if historyA[i] = tmpSum then
        count2 := count2 + 1;;
    end;
    if (count <> 1) and (count2 <> 1) then
    begin
      writeln('Одинаковых столбцов суммы ', tmpSum, ' = ', count);
      historyA[j] := tmpSum;
    end;
  end;
  readln;
end.

Pascalabc.net нужна ! в заданой матрице размер которой указывает пользователь, а элементы образуются
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота