Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
zziimmbboo
04.03.2022 20:53 •
Информатика
Напишите программу которая для числа выводит значение тригонометрических функцийю sin и cos например вводим 180 программа выводит sin(180)=0 и cos(180)=-1
Показать ответ
Ответ:
ананастенька21000
20.09.2020 07:25
Вот программа и результат ее работы (смотри скриншоты)
А вот ее листинг:
uses Crt;
var alfa, a, s, c:real;
begin
ClrScr;
Write (' alfa = ');
ReadLn (alfa);
a:= alfa*pi/180;
s:=sin(a);
c:=cos(a);
WriteLn;
WriteLn ( 'sin','(',alfa:3:0, ') = ', s:6:2);
WriteLn ( 'cos','(',alfa:3:0, ') = ', c:6:2);
ReadLn;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
roofman93p08nel
19.09.2021 09:10
Числа фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765, …, в которой каждое...
Chopykoe
19.09.2021 09:10
Сколько понадобится дискет, чтобы заменить 1 тб?...
troft
19.09.2021 09:10
Дано масив а[n..1] скласти програму яка в масиві всі додатні числа збільшує на 2 а всі від ємні числа зменшує на 2 паскаль...
MCKOLYA
19.09.2021 09:10
Написать программу в паскале для p=1*1/2*1//n и s= sqrt(1)+sqrt (1+2)+sqrt(1+ (1+n)...
ruslanalsibaev
03.07.2020 23:27
ответ необходимо давать в виде число ; число Например, если цикл выполняется 5 раз, а значение переменной будет равно 10, то в ответе необходимо указать строку 5;10...
aigamal
01.08.2022 23:41
Аответьте на вопросы. 1. Почему детство будущего поэта нельзя назвать счастливым?2. Как вы понимаете смысл предложения «Так началась его горькая жи3. Объясните смысл...
jjjustangel1
01.08.2022 23:41
Удобно располагается у стеныКопирМасштабирование25-400%До 8 копий на1 стр.Лазерный принтер Цветной сканерДо.182019 200(формат А4)стр минТочдом(антерпотрованное)...
никлася
19.11.2022 10:58
Написание на языке Паскаль.. Работа и путешествияОрганизация “Travel & Work” предоставила список из 10 стран, в которых можно поработать в летнее время, и стоимости...
niktos30042002
08.07.2022 04:45
Данные – это: а) информация, которая обрабатывается компьютером в двоичном компьютерном коде б) последовательность команд, которую выполняет компьютер в процессе обработки...
mayorova4
10.06.2022 16:07
Дано 1 переменная, введите в эту переменную целое числа, используя ввод с клавиатуры. Напишите программный код, определяющий в каком отрезке число находиться. (-100:-10)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
А вот ее листинг:
uses Crt;
var alfa, a, s, c:real;
begin
ClrScr;
Write (' alfa = ');
ReadLn (alfa);
a:= alfa*pi/180;
s:=sin(a);
c:=cos(a);
WriteLn;
WriteLn ( 'sin','(',alfa:3:0, ') = ', s:6:2);
WriteLn ( 'cos','(',alfa:3:0, ') = ', c:6:2);
ReadLn;
end.