Напишите программу, которая генерирует список из 20 случайных целочисленных элементов
из диапазона от 1 до 100, определяет и выводит на экран:
а) сумму нечётных элементов;
о) количество двухзначных элементов;
в) минимальный элемент, оканчивающийся на 4.
следует считать, что в списке обязательно есть хотя бы один элемент,
оканчивающийся на 4.
Решение, которое перебирает
Большие буквы стоят в таблице кодов подряд, то есть, образуют диапазон, нам требуется проверить лежит ли буква в заданном диапазоне. Для русских букв проверять будем так:
if ('А' <= str[0] && str[0] <= 'Я'), для английских нужно просто поменять буквы на английские.
Пример для русских букв:
Программа выводит заглавные буквы
#include <iostream>
#include <string>
#include <windows.h>
signed main() {
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
std::string str;
getline(std::cin, str);
if ('А' <= str[0] && str[0] <= 'Я')
std::cout << "Первая буква является заглавной!";
else
std::cout << "Этот символ не является заглавной буквой!";
return 0;
}
1. Input devices allow you to enter information into a computer for further storage and processing, and output devices allow you to receive information from a computer.
2. Input device types: mouse, keyboard. output device types: monitor.
3. However, regardless of the forms in which they receive their inputs, all input devices must provide a computer with data thare transformed into the binary codes that the primary memory of the computer is designed to accept. This transformation is accomplished by units called I/O interfaces.
4. A reel of magnetic tape upon which the collected data are stored in binary format is an example of a human-independent output.
5. Data enter input units in forms that depend upon the particular device used. For example, data entered from a keyboard in a manner similar to typing, and this differs from the way that data are entered by bar-code scanner.
6. The major differences between devices are the media that they use and the speed with which they are able to transfer data to or from primary storage.
7. It should be noted that the high-speed devices are entirely electronic in their operation or magnetic media that can be moved at high speed.
8. The low-speed devices are those with complex mechanical motion or operate at the speed of a human operator.
Объяснение: