В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая генерирует список из N элементов в диапазоне от -100 до 100. Вывести список на экран. Удалить из списка первый отрицательный элемент (если такого нет, то ничего не удалять). Снова вывести список на экран.

Показать ответ
Ответ:
Motornerplay
Motornerplay
28.10.2022 16:30
Денежные знаки - это пример смешанной системы счисления. Сейчас в России используются монеты и купюры следующих номиналов: 1 коп., 5 коп., 10 коп., 50 коп., 1 руб., 2 руб., 5 руб., 10 руб., 50 руб., 100 руб., 500 руб., 1000 руб. и 5000 руб. Чтобы получить некоторую сумму в рублях, нам нужно использовать некоторое количество денежных знаков различного достоинства. Предположим, что мы покупаем пылесос, который стоит 6379 руб. Чтобы расплатиться, нам потребуется шесть купюр по тысяче рублей, три купюры по сто рублей, одна пятидесятирублёвая купюра, две десятки, одна пятирублёвая монета и две монеты по два рубля. Если мы запишем количество купюр или монет начиная с 1000 руб. и заканчивая одной копейкой, заменяя нулями пропущенные номиналы, то мы получим число, представленное в смешанной системе счисления; в нашем случае — 603121200000. 

В непозиционной системе счисления величина числа не зависит от положения цифры в представлении числа. Если бы мы перемешали цифры в числе 603121200000, то мы бы не смогли понять, сколько стоит пылесос; в непозиционной системе случится нечто похожее. Ярким примером непозиционной системы счисления является римская система.
0,0(0 оценок)
Ответ:
bigofficerjor
bigofficerjor
09.02.2021 18:05
Если число произвольное, то оно может содержать произвольное количество цифр, большее нуля. Число считается натуральным, поэтому наложим на ввод ограничения: вводить нужно только цифры, а остальные знаки будут игнорироваться. В этом случае количество цифр в числе будет равно количеству введенных цифр. Число вводим, как символьную строку, а затем при подсчете цифр пропускаем все нецифровые символы.

const
  digits=['0','1','2','3','4','5','6','7','8','9'];
var
  s:string;
  i,k:integer;
begin
  Write('Введите произвольное натуральное число: ');
  Readln(s);
  k:=0;
  for i:=1 to Length(s) do
    if s[i] in digits then Inc(k);
  Writeln('Количество цифр в числе равно ',k)
end.

Тестовые решения:

Введите произвольное натуральное число: -43546543235.08754
Количество цифр в числе равно 16

Введите произвольное натуральное число: 96435034623
Количество цифр в числе равно 11

Введите произвольное натуральное число: И даже так: -43 323 453.657 4 посчитает!
Количество цифр в числе равно 12
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота