В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ОСА717
ОСА717
03.11.2022 02:04 •  Информатика

Напишите программу, которая ищет сколько раз символьная последовательность встречается в слове(решать подробно, через write, length delete и т. п)

Показать ответ
Ответ:
Rayanachechenka
Rayanachechenka
09.10.2020 12:45

Входные данные

На вход программы подаются две символьные строки, каждая строка завершается символом "конец строки".

Выходные данные

Программа должна вывести все символы, которые встречаются в обеих строках, в порядке возрастания их ASCII-кодов. Если таких символов нет, нужно вывести слово 'NO'.

Примеры

входные данные

qwerty

asdqwhy

выходные данные

qwy

входные данные

qwerty

12345

выходные данные

NO

Pascal ABC 1.8 Программа должна быть составлена по теме множества

var set1: Set of Char;

   set2: Set of Char;

   s1, s2: string;

   i: integer;

   done: boolean;

   c: char;

begin

set1 := [];

set2 := [];

readln(s1);

readln(s2);


for i := 1 to length(s1) do

 include(set1, s1[i]);


for i := 1 to length(s2) do

 include(set2, s2[i]);


done := False;

for c := #0 to #255 do

 if (c in set1) and (c in set2) then

 begin

   done := True;

   write(c);

 end;


if not done then

 write('NO');


writeln;

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота