В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [100812; 100923], числа, имеющие ровно 6 различных делителей. Выведите эти делители для каждого найденного числа в порядке возрастания.

Показать ответ
Ответ:
alieksandra10981
alieksandra10981
03.12.2020 10:58

1 17 289 349 5933 100861

1 2 4 25219 50438 100876

1 2 4 25229 50458 100916

1 3 9 11213 33639 100917

Объяснение:

from math import sqrt

for n in range(100812, 100923 + 1):

   divs = []

   for div in range(1, round(sqrt(n)) + 1):

       if n % div == 0:

           if div == n // div:

               divs += [div]

           else:

               divs += [div, n // div]

       if len(divs) > 6:

           break

   if len(divs) == 6:

       print(' '.join(str(div) for div in sorted(divs)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота