В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Монтер111
Монтер111
19.07.2022 15:14 •  Информатика

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [244143; 367821], числа, имеющие ровно 5 различных делителей. выведите эти делители для каждого найденного числа в порядке возрастания.

Показать ответ
Ответ:
sayfulloevo
sayfulloevo
12.04.2019 18:00

uses crt;

var i,sum,k: integer;

begin

      sum: =0;

      k: =0;

      writeln('вводите числа. 0 - конец последовательности');

      repeat

          read(i);

          if i mod 2=1 then begin

              sum: =sum+i;

              inc(k);

          end;

      until i=0;

      writeln;

      writeln('среднее  арифметическое нечетных чисел: ',sum/k: 5: 3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота