Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [258274; 258297], числа, имеющие ровно 4 различных делителя. Выведите эти четыре делителя для каждого найденного числа в порядке возрастания.
Тут есть два варианте решения, у Вас в задании написано что число Х и число А уже даны, то бишь с клавиатуры вводить их не надо. Тогда 1 вариант решения 1. и 2. задания: 1) var x: integer; begin x:=5; // Поменяйте значение на нужное writeln ('Квадрат числа ', x, ' = ',sqr(x)); end. 2) var a,b: integer; begin a:=3; // Поменяйте значение на нужное b:=a*2; writeln ('Сумма A и B = ', a+b); end. 2 вариант решения, все значения вводятся с клавиатуры: 1) var x: integer; begin write ('Введите число Х: '); read(x); writeln ('Квадрат числа ', x, ' = ',sqr(x)); end. 2) var a,b: integer; begin write ('Введите число А: '); read (a); b:=a*2; writeln ('Сумма A и B = ', a+b); end.
1)
var x: integer;
begin
x:=5; // Поменяйте значение на нужное
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
a:=3; // Поменяйте значение на нужное
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
2 вариант решения, все значения вводятся с клавиатуры:
1)
var x: integer;
begin
write ('Введите число Х: '); read(x);
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
write ('Введите число А: '); read (a);
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do numb[i]:=random(101);// задает последовательность
for i:=1 to 100 do
begin
write(',',numb[i]); // вывод на экран последовательность(можно удалить)
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
end;
if f=0 then writeln('Yes') else writeln('No');
end.
program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do begin
numb[i]:=random(101);// задает последовательность
write(' ',numb[i]);//вывод на экран, можно удалить
end;
writeln;
i:=0;
repeat
i:=i+1;
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
until i<100;
if f=0 then writeln('Yes') else writeln('No');
end.