В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
marina0708
marina0708
20.02.2020 20:19 •  Информатика

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [428111; 489335] число c максимальной суммой делителей, имеющее не более четырех делителей. Для найденного числа выведите сумму делителей, количество делителей и все делители в порядке убывания. ответ записывайте в одну строку, делители разделяйте пробелом.

Показать ответ
Ответ:
Сацуки001
Сацуки001
20.02.2021 14:26

//двумерный массив в c++ ПИШЕТСЯ ТАК MASSIV [10][7];

//это программа на консольное приложение

#include <stdio.h.>

#include <windows.h>

#include  <time.h>

int nechetnoe;

int MASSIV [10][7];

int main(void){

srand(time(NULL)); //чтобы не было псевдорандома

//используем вложенный цикл для перебора значений массива

for(int i=0;i<7;i++){

for(int c=0;c<10;c++){

massiv[c][i]=rand();

if ((massiv[c][i]%2)!=0)

nechetnoe++;

}

printf("Количество нечётных элементов массива =  %d",nechetnoe);//вывод на консоль

Sleep(100000)

}

Объяснение:

Надеюсь все понятно

0,0(0 оценок)
Ответ:
Надя0301
Надя0301
30.06.2021 14:46

вот ответ

Объяснение:

Таблицы ASCII кодов

Ниже предоставленные таблицы ascii кодов символов. Если вы не совсем понимаете, как их использовать, наберитесь терпения и прочтите последний пункт статьи.

Таблица ascii кодов: ASCII (American Standard Code for Information Interchange)

Dec Hex Char   Dec Hex Char   Dec Hex Char   Dec Hex Char

0 0 NUL 32 20 (sp) 64 40 @ 96 60 `

1 1 SOH 33 21 ! 65 41 A 97 61 a

2 2 STX 34 22 " 66 42 B 98 62 b

3 3 ETX 35 23 # 67 43 C 99 63 c

4 4 EOT 36 24 $ 68 44 D 100 64 d

5 5 ENQ 37 25 % 69 45 E 101 65 e

6 6 ACK 38 26 & 70 46 F 102 66 f

7 7 BEL 39 27 ' 71 47 G 103 67 g

8 8 BS 40 28 ( 72 48 H 104 68 h

9 9 TAB 41 29 ) 73 49 I 105 69 i

10 A LF 42 2A * 74 4A J 106 6A j

11 B VT 43 2B + 75 4B K 107 6B k

12 C FF 44 2C , 76 4C L 108 6C l

13 D CR 45 2D - 77 4D M 109 6D m

14 E SO 46 2E . 78 4E N 110 6E n

15 F SI 47 2F / 79 4F O 111 6F o

16 10 DLE 48 30 0 80 50 P 112 70 p

17 11 DC1 49 31 1 81 51 Q 113 71 q

18 12 DC2 50 32 2 82 52 R 114 72 r

19 13 DC3 51 33 3 83 53 S 115 73 s

20 14 DC4 52 34 4 84 54 T 116 74 t

21 15 NAK 53 35 5 85 55 U 117 75 u

22 16 SYN 54 36 6 86 56 V 118 76 v

23 17 ETB 55 37 7 87 57 W 119 77 w

24 18 CAN 56 38 8 88 58 X 120 78 x

25 19 EM 57 39 9 89 59 Y 121 79 y

26 1A SUB 58 3A : 90 5A Z 122 7A z

27 1B ESC 59 3B ; 91 5B [ 123 7B {

28 1C FS 60 3C < 92 5C \ 124 7C |

29 1D GS 61 3D = 93 5D ] 125 7D }

30 1E RS 62 3E > 94 5E ^ 126 7E ~

31 1F US 63 3F ? 95 5F _ 127 7F DEL

Расширенная таблица кодов ASCII

Dec Hex Char   Dec Hex Char   Dec Hex Char   Dec Hex Char

128 80 Ç 160 A0 á 192 C0 . 224 E0 α

129 81 ü 161 A1 í 193 C1 2 225 E1 ß

130 82 é 162 A2 ó 194 C2 0 226 E2 Γ

131 83 â 163 A3 ú 195 C3 / 227 E3 ∏

132 84 ä 164 A4 ñ 196 C4 ) 228 E4 ∑

133 85 à 165 A5 Ñ 197 C5 3 229 E5 σ

134 86 å 166 A6 ª 198 C6 G 230 E6 μ

135 87 ç 167 A7 ° 199 C7 K 231 E7 τ

136 88 ê 168 A8 ¿ 200 C8 9 232 E8 Φ

137 89 ë 169 A9 _ 201 C9 6 233 E9 Θ

138 8A è 170 AA ¬ 202 CA = 234 EA Ω

139 8B ï 171 AB ½ 203 CB ; 235 EB δ

140 8C î 172 AC ¼ 204 CC : 236 EC ∞

141 8D ì 173 AD ¡ 205 CD 4 237 ED φ

142 8E Ä 174 AE « 206 CE > 238 EE ε

143 8F Å 175 AF » 207 CF N 239 EF ∩

144 90 É 176 B0 ░ 208 D0 J 240 F0 ≡

145 91 æ 177 B1 ▒ 209 D1 L 241 F1 ±

146 92 Æ 178 B2 ▓ 210 D2 H 242 F2 ≥

147 93 ô 179 B3 * 211 D3 F 243 F3 ≤

148 94 ö 180 B4 1 212 D4 B 244 F4 ⌠

149 95 ò 181 B5 I 213 D5 ? 245 F5 ⚥

150 96 û 182 B6 1 214 D6 C 246 F6 ÷

151 97 ù 183 B7 D 215 D7 O 247 F7 ≈

152 98 _ 184 B8 @ 216 D8 P 248 F8 0

153 99 Ö 185 B9 < 217 D9 - 249 F9 .

154 9A Ü 186 BA 5 218 DA + 250 FA .

155 9B ¢ 187 BB 7 219 DB $ 251 FB √

156 9C £ 188 BC 8 220 DC ( 252 FC _

157 9D ¥ 189 BD E 221 DD % 253 FD ²

158 9E _ 190 BE A 222 DE ▐ 254 FE ▀

159 9F ƒ 191 BF , 223 DF & 255 FF  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота