В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lotoskei
lotoskei
06.11.2022 16:59 •  Информатика

Напишите программу, которая, используя оператор repeat, которая считывает с клавиатуры вещественное число х и выводит на экран у= √ 2х.​

Показать ответ
Ответ:
БелыйЯд
БелыйЯд
07.02.2023 07:00

схема и объяснение снизу

program ufhcn;

var x, y, a, i, b: real;

uses crt;

begin

clrscr;

writeln('вводи число 1');

readln(i);

writeln('вводи число 2');

readln(x);

if (x> =0) then writeln('все в порядке')

else writeln('не правильная цифра');

if (i> =1) and (i< =13)

then writeln('число входит в ряд', x*i> =a)

else writeln('не входит ряд');

writeln('води число 3');

readln(a);

if (a> =0) then writeln('вводи число 4');

readln(b);

if (b> =0) then writeln('находим первый y= ', a*x*(i*i*i)+b*sqrt(x*i));

if (b< 0) then writeln('находим второй y= ', (sin(x)/cos(x))*(a-(x*

end.

начало

вводим переменную i

вводим переменную x

если x> =0 то

если нет если да

то нет. то далее

ввели интервал в переменную i

если (i> =1) и (i< =12) то

если нет. если да

то нет решения. то есть решение

вводим число 3

если (а> =0) то

вводим число 4

если (b> =0) то

y1= a*x*(i*i*i)+b*sqrt(x*i))

если (b< 0) то

y2= ', (sin(x)/cos(x))*(a-(x*

конец

короче объясняю.

ввёл 4 переменных

сделал так чтобы все вводимые были больше нули или равны ему чтобы легче было.

ввёл интервал i от 1 до 12

остальное решает уравнение поле ввода 4 переменных, если что-то не устроило пиши разберусь

0,0(0 оценок)
Ответ:
jyljokgorsheni1
jyljokgorsheni1
01.05.2022 21:27

будем рассуждать подробно:

1. вы­пол­ним дей­ствия поль­зо­ва­те­ля в об­рат­ном по­ряд­ке, на­чи­ная из с: \учёба\ма­те­ма­ти­ка\гиа. под­ни­мем­ся на два уров­ня вверх, ока­жем­ся в с: \учёба. те­перь, спу­стив­шись на один уро­вень вниз, мы долж­ны ока­зать­ся в ка­та­ло­ге рас­пи­са­ние. таким об­ра­зом, ис­ход­ный ка­та­лог имеет пол­ный путь с: \учёба\рас­пи­са­ние.

пра­виль­ный ответ: 2

2. аналогично, вы­пол­ним дей­ствия поль­зо­ва­те­ля в об­рат­ном по­ряд­ке, на­чи­ная из с: \учёба\информатика\гиа. под­ни­мем­ся на один уро­вень вверх, ока­жем­ся в с: \учёба\информатика. те­перь, спу­стив­шись на два уров­ня вниз, мы долж­ны ока­зать­ся в ка­та­ло­ге рас­пи­са­ние. таким об­ра­зом, ис­ход­ный ка­та­лог имеет пол­ный путь с: ­пи­са­ние.

пра­виль­ный ответ: 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота