В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tyy6
tyy6
30.04.2022 15:00 •  Информатика

Напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1],а[3]... и т.д.). Если количество элементов нечётное,то последнее число должно оставаться на месте питон ​

Показать ответ
Ответ:
NObrains0
NObrains0
05.03.2021 18:00

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(' '.join([str(i) for i in a])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота