В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
070520031
070520031
17.02.2021 04:43 •  Информатика

Напишите программу,которая находит и выводит все трехзначные числа,средняя цифра которых равна сумме первой и второй цифр ​

Показать ответ
Ответ:
tanyucsgha
tanyucsgha
07.06.2020 00:51

Стандартный алгоритм на плюсах:

НО  мне кажется что в задании есть опечатка и нужно найти числа, где средняя равна сумме первой и третьей.

Навсякий приведу и тот и тот вариант

1) Вариант(КАК В ЗАДАНИИ)

#include <iostream>

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){

               for (size_t b =0;b<=9;++b){

                       for (size_t c = 0; c<=9;++c){

                               if (b == a+b)

                                       cout << a << b<<c << endl;

                       }

               }

       }

return 0;

}

2) Вариант2 (как я думаю)

#include <iostream>

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){

               for (size_t b =0;b<=9;++b){

                       for (size_t c = 0; c<=9;++c){

                               if (b == a+c)

                                       cout << a << b<<c << endl;

                       }

               }

       }

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота