В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dianapavliska2
dianapavliska2
10.09.2022 06:33 •  Информатика

Напишите программу,которая находит максимальный и минимальный из элементов массива с четными положительными значениями.если в массиве нет элементов с четными положительными значениями,нужно вывести сообщение об этом. с объяснением!

Показать ответ
Ответ:
Krst263
Krst263
27.07.2020 22:59

const n = 10; //В константе n указываем количество элементов в массиве

var a:array[1..n]of integer;

i,s,max,min:integer;

begin

write('Массив: '); //Вывод на экран слова "Массив: "

for i:= 1 to n do //Цикл с параметром для последовательной обработки массива

begin

a[i]:= random(21)-10; //Заполнение массива случайными числами из промежутка [-10,10]

if (a[i]>0){//Проверяем положительный элемент или нет} and (a[i] mod 2 = 0){//Проверяем чётный элемент или нет} then s:=s+1; //В переменной s будет считаться количество чётных положительных элементов при выполнении, указанных условий

write(a[i],'  ') //Вывод на экран массива в строку

end;

writeln; //Переход на новыю строку

if s=0 then write('Чётных положительных элементов в массиве нет') //Вывод на экран сообщения "Чётных положительных элементов в массиве нет" и завершение программы

else //Продолжении программы при нахождении хотя бы 1-го чётного положительного элемента

begin

max:=2; //Т.к. 2 минимальное чётное положительное число, то присваиваем это значение переменной max

for i:= 1 to n do //Поиск max элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]>max){//Проверяем больше текущий элемент max или нет} then max:=a[i]; //Присваиваем переменной max значение текущего элемента при выполнении, указанных условий

min:=max; //Т.к. max значение элемента массива уже найдено, то переменной min присваиваем значение переменной max

for i:= 1 to n do //Поиск min элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]<min){//Проверяем меньше текущий элемент min или нет} then min:=a[i]; //Присваиваем переменной min значение текущего элемента при выполнении, указанных условий

if max=min then write ('Максимальным и минимальным чётным положительным элементом является один и тот же элемент: ',max) //Вывод на экран результатов

else

begin

writeLn('Максимальный чётный положительный элемент: ',max);//Вывод на экран результатов

write('Минимальный  чётный положительный элемент: ',min)//Вывод на экран результатов

end

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота